Always float panel on KDE 6

I don’t know if this is currently possible and perhaps I am missing where the setting is? I very much prefer to have my panel always floating, however with 6 when I maximize or attempt to utilize the built in kind of tile snap thing (sorry I don’t know the name) it unfloats. Is there a way I can change this?

In the panel settings there is:
Visibility → Windows go below

Does that work for you? Or should fullscreen windows stay above the panel?

Thanks for the response!
From my test, go below seems to act more like a ‘Go behind’ causing the application bar/menu to be stuck behind the panel unreachable so to say rather than further down on the screen. I’m not sure if that’s how it was intended to work.

Example of desired behavior as of course sometimes wording around such things can be tricky! In this example I am using ‘start’ [0,0] X/Y Axis as top left of the screen or individual window.

Panel is 48 px wide, the tile gap thing is set to 4px.
Start of window snapped or maximized should start on [X,53]

Yes correct.

Unfortunately a true floating panel is currently not planned due to a lack of resources: 462838 – Option to have a true floating panel mode.

I gotcha. In relation to the link: Interesting! I do know the example was the outcome behavior in 5.27 for the most part. I actually can’t confirm the maximize part as I only used the tile/snap thing. Sounds like I would have experienced this if I did maximize anything as it looks like comment 4 mentions utilizing it the same way I was to get around the defloating. I wonder what changed that it now affects tiling as well?

Regardless I understand with all the individual complexities it may have got lost through changes in functionality of involved systems or even in order to solve other issues. I do think I remember hearing in one of Nicco’s videos there being some difficulties with the floating panel as well. I actually have only been on Linux in general for about 3 months now so there’s quite a lot I have been taking in!

Thanks for your time!

1 Like

Yes, this will be a really nice feature. This time i have disabled the floating panel completely. Because if have on the first Desktop a floating panel because windows are not maximised, but on the second desktop windows are maximised and you change the desktop, then everything is flapping extremely. This also applies when minimising the last window so that a fixed panel becomes a floating panel again.