Application in Autostart "not started yet" even though I restarted plenty of times already

I use Victor-IX’s Blender-Launcher-V2, and added it to Autostart days ago using the button Add > Add Application. But after many reboots, it is still not autostarting, and Autostart itself calls it “Not autostarted yet”.

When I click it, Autostart says it will display details after the system is restarted, but as I said: it already did many times.

image

I tried removing it and adding it again from Autostart, I also tried making my own shortcut in ~/.config/autostart/, copying the Blender Launcher.deskto file from ~/.local/share/applications/ to ~/.config/autostart/ . None of these autostarted Blender Launcher.

I can also just run that app from any of the shortcuts made by Autostart or myself with no issue. But it does not want to run at startup like the other apps do there.

1 Like

Can you post the content of the autostart launcher file here?

I think this could be the same as this bug report: 484207 – Autostart KCM doesn't work with desktop files containing spaces

Try to change the file name of the desktop launcher file in the ~/.config/autostart folder to not have spaces in the file name.

1 Like

Here’s the content of Blender Launcher.desktop:

[Desktop Entry]
Comment[en_US]=Standalone client for managing official builds of Blender 3D.
Comment=Standalone client for managing official builds of Blender 3D.
Exec='/home/roikku/MyApps/Blender/Blender Launcher'
GenericName[en_US]=
GenericName=
Icon=/home/roikku/MyApps/Blender/bl.ico
MimeType=
Name[en_US]=Blender Launcher
Name=Blender Launcher
NoDisplay=false
Path=
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
X-KDE-RunOnDiscreteGpu=false
X-KDE-SubstituteUID=false
X-KDE-Username=

I will try renaming it to Blender_Launcher.desktop and see how it goes.


Edit

After rebooting, this time the entry is marked as failed, so we are getting somewhere!

It seems like it doesn’t like the space in the executable file itself, but shouldn’t the quotation marks prevent that?

The Desktop Entry file is incorrect. As per the Desktop Entry specification, the Exec key must be quoted using double quotes.

I expect that should solve the problem.

1 Like

I changed to double quote and rebooted, still not autostared and same error messages in the log.

Note that double-clicking the file to run it works as expected regardless of it using simple or double quotes in the exec key.

Can you please share the output of running this command: systemctl cat --user app-Blender_Launcher@autostart.service ?

(I made a guess about the name of the service file - if it is wrong, try to locate it using systemctl list-units --user | grep autostart )

1 Like

There it is:

$ systemctl cat --user app-Blender_Launcher@autostart.service 
# /run/user/1000/systemd/generator.late/app-Blender_Launcher@autostart.service
# Automatically generated by systemd-xdg-autostart-generator

[Unit]
Documentation=man:systemd-xdg-autostart-generator(8)
SourcePath=/home/roikku/.config/autostart/Blender_Launcher.desktop
PartOf=graphical-session.target

Description=Blender Launcher
After=graphical-session.target

[Service]
Type=exec
ExecStart=:/home/roikku/MyApps/Blender/Blender Launcher
Restart=no
TimeoutSec=5s
Slice=app.slice
WorkingDirectory=-

As you can see, the resulting ExecStart= line does not quote the executable name.

This looks like a bug in systemd-xdg-autostart-generator - I opened a bug report about this here: systemd-xdg-autostart-generator does not correctly quote paths for `ExecStart=` · Issue #32173 · systemd/systemd · GitHub

1 Like

I was just told by the systemd maintainers that this issue is fixed in systemd 251.

@Lauloque you never mentioned what OS you are running, but if its is Neon then I can say that the next Ubuntu LTS (coming out shortly) features systemd 255 - so when Neon rebases on top of that (should be around August through October, depending on which track you are following, if history is any indication) this issue will be finally resolved.

In the mean time - make sure the executable you are launching does not need escaping - possibly by creating a symlink with a simpler name and executing that.

1 Like

Did you find out if the launcher even works once you noticed it hand’t worked?

Obviously it’s not working, and so it never launched.

1 Like

Yes the app itself works normally. I can also run it by double-clicking the .desktop file in the autostart folder.

Indeed, I am on KDE Neon 6.0.3.

I made a symlink named Blender_Launcher and used that in Autostart, it autostarts successfully at startup \o/

Thanks for the help, I will wait for the update and come back here if there’s any issue from there.

1 Like