Application shortcuts created in K Menu Editor do not save

After some faffing about with Firefox through snap, I decided to install manually by downloading the firefox tar.bz2 and unpacking it into a .firefox folder in my home directory. This has worked fine overall, but came with the side effect that there’s no shortcut for it, so I can’t set it as my default browser or select it for dialogs involving opening https:// stuff (like opening links in Thunderbird and whatnot.)

So: easy solution, just make a custom application shortcut in K Menu Editor. I fill my application out how I like it, and hit save.

All good. I open up the start menu to make sure, aaaaaand nothing (you’ll have to imagine the lack of firefox, I already used my one image for this post.) My list of applications still updates fine, with stuff I install through Discover getting added, but I cannot create any custom shortcuts through K Menu Editor. Any ideas why?

On kubuntu I always get rid of all snap stuff. I put the regular Firefox in /opt and make a link for it in /usr/bin. The command is simply firefox.

The browser itself works fine, and can be started with a similar command (though it has a filepath before it, as seen above.) The problem is entirely that this custom application shortcut doesn’t save at all; closing and reopening K Menu Edit after hitting save, it’s just gone.

It might also be important to note that I didn’t actually install Kubuntu, I installed base Ubuntu and installed Plasma afterwards.

Note that there are several application menu widgets. Which are you using? Does the problem occur with the others?

I see you have the firefox entry at the top level. If you put a submenu at the top level, and move the firefox item into it, does that stick? I’m wondering if the menu widget is not expecting items at the top level, and wants you to use “favourites” to have an entry at the top level.

I’m using the one that pops up if you right click the application launcher, labeled KDE Menu Editor (also run with the command kmenuedit.) Originally I was trying to put it in the Internet category, I just didn’t bother for this example image. I don’t think favorites is actually an available menu here, and I’d have to add it to that through the application launcher after saving the widget.

You mentioned there were several widgets, what are the other ones?

You mentioned there were several widgets, what are the other ones?

You’ve called it the “Application Launcher”. If you right-click it, there’s a “show alternatives” option; that stopped working on this install some number of release upgrades ago. The one I use is “Application Menu” and I’ve used “Application Dashboard” sometimes. There’s quite a few more through “Add Widgets”, “Get New Widgets…”

Switching widgets didn’t fix anything, probably because it’s KDE Menu Editor that’s being unhelpful.

If you still have the other firefox installed, what is its name and comment?

I have not had the Snap version installed for a long time. The name was just “Firefox” and I don’t remember the comment.

I asked because if it’s still listed as web browser ( somewhere), that could be confusing. What happens if you type firefox?

It shows the tar.bz2 file I unpacked to install it, and the window I have open right now. It used to show an option to install Firefox through snap, but I deactivated snap recently, following the guide here: software uninstall - How to remove snap from Ubuntu? - Ask Ubuntu


Exactly. Like I said, me personally,I usually unpack a regular to /opt ( you could do it in your home directory of course). After that I make a link to it ( as root) in /usr/bin. That’s an option. Currently your system has no idea what on earth firefox is when you try to launch it from a terminal.
How to install firefox regular

So, it turned out my issue was a bit larger than I thought; nothing saved. I could delete applications, break commands, change icons, and more, but even after hitting save, it never updated in any application widget. Even through reboots, nada.

Then I tried running it through the terminal, where it spat out this error when I created a New Item called Firefox:

~$ kmenuedit The desktop entry file "/home/zachary/.local/share/applications/Firefox.desktop" has Type= "Application" but no Exec line

So, I figure I should go check this directory out. Except there’s no applications folder in /.local/share. There IS a 0 byte file that’s registered as an “empty document (application/x-zerosize)” named applications, but no applications folder.

Am I right to assume this is very bad?

(Also, I made that shortcut, very useful! The command I was using in the og image did actualy work, and adding the shortcut doesn’t seem to have added it to the application launcher, but still useful!)

Alright, long and short of it is that I can manually create working .desktopfiles by going into ~/usr/share/applications. I can then manually change the default applicaitons to my new shortcuts by editing ~/.config/mimeapps.list. My question now is back to the original: if I can do this manually, why is KDE Menu Editor failing to do it automatically?