Audio clipping, how to fix that?

I’ve encounted problem that appears to have on all distro’s i used. And KDE Neon have this issue too.

When your audio slider on 100% you can hear audio clipping/distorted. Of course you can make it 90-80% but i never had a problem with that on windows. I had to purposly increase volume in the same audacity to have that effect.

I had same problem on Android devices, but making preamp on -5 / -10 makes it sound without distortion. And because im using bluetooth headphones - i have enough power to listen music at full volume even with lower preamp.

On my Desktop im using mini-jack powered headphones, And lowering volume is strongly felt, and in many cases I really want to turn up the volume. But I can’t because my sound will be ruined.

Are there any solutions? I tried to solve this on the same Linux Mint, but there I was never able to solve this problem.

Info from pactl info:

Server line: /run/user/1000/pulse/native
Library protocol version: 35
Server protocol version: 35
Runs locally: yes
Client number: 65
Memory block size: 65472
Username: bxg
Hostname: bxg-b450ms2h
Server name: pulseaudio
Server version: 15.99.1
Default sample specification: s16le 2-channel 4410
Default channel layout: front-left,front-right
Default audio receiver: alsa_output.pci-0000_0c_00.6.analog-stereo
Default source: alsa_output.pci-0000_0c_00.6.analog-stereo.monitor
Cookie: aaeb:ad67

alsamixer

  • select sound device with F6
  • raise PCM volume to full (or 84% to avoid distortion)

Its not a solution. It still messes up audio even with lower volume.

it’s a whole ass rabbit hole (at least it was for me), but i was able to get some of my audio tracks to play nice using rsgain.

certain tracks just sounded way distorted but rsgain was able to dial them down several db and then they sounded better and played at the same volume as everything else.

other tracks were too soft and they got a db boost so they sounded better amongst all the the others during random playback.

you will need an audio player that can utilize realgain tags tho, such as:

clementine
gmusicbrowser
rhythmbox

Most likely the Window driver is applying some extra internal settings/fixes to the card which aren’t ported to the Linux driver.

This is very common and depending on the device sometimes an updated driver fixes the problem, if the device is less than a year old trying the latest kernel may help.

Other times applying specific model (provided that it the fix (referred as quirks) exists in the kernel)

https://help.ubuntu.com/community/HdaIntelSoundHowto#Manually_Specify_Module_Parameters

https://docs.kernel.org/sound/hd-audio/models.html

If that doesn’t work then , if you are adventurous enough you may dive into this How to sniff verbs from a Windows sound driver · ryanprescott/realtek-verb-tools Wiki · GitHub an alternative for realtek cards is to use the tool mentioned here Linux for ROG Notebooks

That last method is what fixed the low volume after suspend + crackling in some hp and probably other laptop models with the alc295 codec, including mine, of which I initially found the fix for here Comment #17 : Bug #1648183 : Bugs : alsa-driver package : Ubuntu

Im really starting to hate linux just because most basic thing you wanna to use, not even work propertly. Ehat the point of using linux as daily basis if solution of 1 very nasty problem gonna cost you days of life.

I literaly cant listen to heavy tracks because my audio will trash up. And EQ will not solve the problem. I know that.

Im searching permanent solution to make audio output sound NORMAL not modified by eq.

itunes has a thing called “loudness” you could just toggle…

the closest thing i could find to that in linux land was rsgain

also, as the other poster mentioned, window programs like to futz with your device’s firmware (if it has any) and that can throw linux for a curve because linux has no way to tell if it’s been tampered with.

i had to go back into windows and reset all my keyboard mods back to factory settings so that my F keys would work under linux… that’s the kind of thing to look out for.

Server Name: PulseAudio (on PipeWire 1.0.6)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right

I’m curious why you don’t have PipeWire there.

I’m using ia B550m, but have never had any issues with any clipping. With Surround set, if I play more channels then it also plays through all channels and there’s no clipping unless the source material is flawed.

Now what you’re saying is that you have the same issue with all distributions - I am confident that it is not your choice of motherboard, and I’m also pretty confident that this isn’t an issue with your settings or user data.

So you have to face the facts - this is not likely an issue with Linux or software.

You haven’t mentioned trying any other path - other than analog… but solutions here related to modifying audio settings isn’t going to fix this (using rsgain is software - this is most likely hardware, possibly related to your laptop).

It’s quite possible that your source recording is bad, and you’re suspecting software/hardware… not information to rule this out.

You also compound the confusion stating that YOU have the same issue with Android.

You must apply some LOGIC when troubleshooting.

  1. I have a problem with Android - audio is clipped on my Android device
  2. I have the same problem with my Laptop
    The logical output from these statements is that the issue is not the Linux software running on your laptop. It could be your headphones!

If I were connected to a monitor or directly to speakers, I’d suspect those.

If connecting to an amplifier/speakers, I’d suspect those.

If the issue occurs ONLY via the audio jack, then I’d suspect the audio jack.

But if the same issue occurs on Android on another device, then I’d simply suspect that you’re confusing the isse and it’ll prove impossible to troubleshoot.

I already typed that i tried to solve it on Linux Mint and it has the same problem. Pulseaudo/Pipewire doesn’t matter. And again - i never had clipping issues on windows, i don’t have dedicated sound card to solve this. And i defenetly not gonna buy new headphones with USB power to just use it on linux.

And im not using laptop, jeez, its desktop PC. I could think that is the problem with drivers on laptop but its literaly standartisied Realted HD Audio. So it should not have this.

Okay, i have only 3 audio outputs

  1. My desktop front speakers (they have amp) - MiniJack
  2. My headphones - MiniJack
  3. Bluetooth headphones - Bluetooth

Im not using bluetooth headphones on PC because i don’t need to. Desktop speakers is connected via front panel, but i didn’t even use it because im trying to solve problem with headphones what connected on my back panel.

I guess i was able to change what minijack is? For some reason my back panel mini-jack is connected as “LineOut” maybe this is the issue? I vividly remember that i had same trouble because my minijack configuration was incorectly setup. But i don’t see any settings to change sound output on minijack…

Sorry, yes - you did say that.

I now take my audio from jacks at the rear, though I wouldn’t power headphones that way, I bought some class-c amplifiers to power speakers (I have a 2.1 and a 2.0 amplifier to give me surround + subwoofer) but I did previously use HDMI to a receiver for audio.

Bluetooth is also perfect.

These things should ‘just work’ between your kernel and hardware (i.e. no installation or adjustment of drivers or settings)…

So maybe a very specific issue with your b450ms2h motherboard - and I can’t do better than search the net for this problem.

I would definitely want to compare HDMI audio output with the mini-jacks too.

Just to share my experience, I have only experienced distortion on Linux (both through speakers and headphones directly connected via RJ45) in two cases:

  • After install* ing the audio equalizer (usually with any configuration that enhances midrange sounds).
  • When the song already has clipping at the top and bottom of the waveform.s

The external speakers are powerful, 2.1 from Logitech, and apart from that, both movies and music can be heard without any problems.

My suggestion: If you have a Linux equalizer enabled, disable it and use a player with a built-in equalizer like QMMP, which is quite versatile and very similar to WinAmp. That’s the one I use and I don’t have any problems.