Audiotube 24.02.2 Flatpak won't launch in Fedora Kinoite 40.20240525.0

Hi. Audiotube 24.02.2 Flatpak won’t launch in Fedora Kinoite 40.20240525.0.

When it wouldn’t launch from the Application Launcher, I tried to run it from the command line:

$ flatpak run org.kde.audiotube 
audiotube: symbol lookup error: audiotube: undefined symbol: _ZN7QtAudio13convertVolumeEfNS_11VolumeScaleES0_, version Qt_6

I have searched for that error, but I haven’t found anything relevant.

Here is more info about my system:

Operating System: Fedora Linux 40
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.0
Kernel Version: 6.8.10-300.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i5-8350U CPU @ 1.70GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Manufacturer: LENOVO
Product Name: 20L6S07G00
System Version: ThinkPad T480

Has anyone had this problem? Should I file a bug?

Thank you!

I can reproduce the problem, looks like an ABI break in the runtime (which shouldn’t happen).

The latest build from flathub should work again

1 Like

Yes it does! Thank you!

@jbb I am facing the same issue in another application. Any details of how you fixed it would be very helpful.

pressing the “start build” button on flathub should be enough.
Since only the binary interface has changed, it should be fine as soon as the application is recompiled.

But after all this is a Qt bug and should not have been necessary.

1 Like