Automatically Index New Files Immediately

Hello,

when I create a new file, for example “45678-test.txt”, it doesn’t get found with Dolphin’s file search or Krunner - only KFind finds it - and also only when being super precise; the keyword needs to be identical and needs to have the file type too. (45678-test = no results; 45678-test.txt = desired result)

How can I set Plasma to always index new files immediately? I think it is important for the search to be reliable in everyday work, but even though Krunner is pretty strong, it loses so much potential when I cannot be 100% sure that the results are correct.

I’ve read articles for about three hours and I’m aware of the baloo-thing.

When checking with systemctl --user status kde-baloo, I can see in the 3rd line that it sometimes fails (Active: failed (Result: signal) and I’m aware that I can reindex with systemctl --user restart kde-baloo.

Still, this doesn’t fix my actual issue - file search being unreliable.

How do you guys do it?

Thanks

1 Like

Which version are you on?

File search has been very flaky in the past for me, but I have just tried this in Dolphin (on Plasma 6.0.5) and had no issues finding the newly-created file.

Today, my distribution updated to 6.0.5 and the problem I described above still happens.

Are you aware of the balooctl6 command? Maybe one of these will give a clue:

balooctl6 status
balooctl6 config show includeFolders
1 Like

In which app did you create the file in question?

Make sure you have “Search Folder Updater” enabled and running, within KDE System Settings >> Session >> Background Services.

Otherwise, Dolphin may not find it, then, just “Refresh” (F5) Dolphin while in Search, and your new file shall appear.

Note that I have removed (or not installed) all Akonadi packages and all Baloo packages – except baloo-widget – and enabling “Search Folder Updater” withing System Settings is enough, for Dolphin automaticly refresh and find new files.

  1. The Background Service was turned on, as the user mentioned below.

  2. Terminal outputs this:

balooctl6 status
Baloo File Indexer is running
Indexer state: Indexing file content
Total files indexed: 1.909.256
Files waiting for content indexing: 718.682
Files failed to index: 1
Current size of index is 3,13 GiB

balooctl6 config show includeFolders
/home/yannik/

I created the test files and directories on the Desktop, which is /home/$USER/Desktop as usual. But I of course tried it somewhere else and it doesn’t get recognized. I created files by just right clicking on the Desktop and creating “test123.txt”, for example.

I’m using KDE for about 2 months and for me, the File Search is unreliable. I can’t be confident that it outputs everything.

I tested it on two machines, both 6.05, my Desktop PC runs KDE Neon User and my Laptop runs TUXEDO OS.

The same exact problem described above still happens.