Autostart Failed: KeePassXC

Used to work fine. Now all of a sudden:

Failed to start org.keepassxc.KeePassXC.
error: Invalid id ‘org.keepassxc.KeePassXC’: Name can’t start with ’

Using X11.

What comes after Name can’t start with ’?

Also have you tried deleting the entry and re-adding it? Sometimes that helped in my case.

That’s all it says. “Name can’t start with '

I did try deleting it and adding it again. Doesn’t help. Seems odd the issue just recently emerged after having KPXC auto-start without issue before today.

How do you add it exactly?

In the settings menu or with a script manually?

Settings. I type Autostart to bring up the entries. KPXC puts an entry in there when I tell it to launch at system startup or I can “Add…” it manually.

I uninstalled the Flatpak and told the AppImage to autostart. It is working correctly.

Maybe if later I install again the Flatpak it will work.

Possibly the AppImage is a better format. I noticed it starts faster and the Flatpak had some major issues when this version, 2.7.8, was initially released. The lead developer quickly fixed the matter.

Ok, so you use a Flatpak, that is always important to know.

Anyways good luck.