Black screen after login (how to troubleshoot Plasma Desktop)

Hello everyone.

After having built KDE Plasma from source following the official documentation, I’m having an issue when I log-in to an X11 session using SDDM :

I’m greeted with a full black screen and my cursor after the loading screen. The window manager KWin seems to work because it can show applications (the windows display fine if I try to run konsole for example).

But no desktop wallpaper, no taskbar, no icons…

I assume there’s a problem in either plasma-workspace or plasma-desktop; my question is :

  • Appart from .xsession-errors and journalctl, is there another file where the error could be logged ?
  • Could you tell me if there’s a way to increase ‘verbosity’ in the logs ?

Thank you in advance, don’t hesitate to ask me for more precisions ! :slight_smile:

It would help if you posted which OS you chose to build Plasma on, and the inform us why you would build it when that are so many great OS’s with it preconfigured.

Sorry. I’m building it on Debian 12 Bookworm and the reason I’m building it from source is because I want to modify it.

1 Like

Word of advice if your Debian version already has a graphical desktop you most likely will have issues trying to use a secondary desktop. They do tend to conflict. I suggest that you ask on the Debian forums about how to go about what you want to do, and on there make sure you provide your inxi and let them know which Plasma apps / components you want.

Thanks, but I’m already starting from a Debian without any prior graphical desktop environment.

In fact, I already asked plenty of times on the Debian mailing list & IRC of developers… but because I’m not using any Debian-specific tools for building, everyone there told me they weren’t competent to help me in that case… :pensive:

I’m sure there must be a way to troubleshoot a Plasma desktop which doesn’t want to start, isn’t it?

1 Like

This means that Plasmashell didn’t assign any containments to the screen. Oops.

If you were using distro packages, I’d say it’s a code bug and I would ask you to submit a bug report. But since you’re building from source, there’s a chance it’s a setup issue.

journalctl is probably your best bet for starters. Filter for the plasma-plasmashell.service; this ought to do it:

journalctl --user-unit=plasma-plasmashell.service --boot 0 --no-pager

Thank you very much ! :slight_smile:

Although I didn’t fix my black screen yet, I’m still making progress by slowly troubleshooting the issues; using journalctl, I could see it was due to a missing daemon kactivitymanagerd.

I’ll keep going, and ask more questions if I’m stuck again.

Yep, that would do it. Make sure it’s built and installed.

If kactivitymanagerd is actually built and installed correctly, then it might be a known code issue: 466193 – Plasmashell sometimes tries to load before kactivitymanagerd has finished loading, and fails.


Now that kactivitymanagerd is built and installed, everything is suddenly much better ! :smiley:
It now loads successfully, with the wallpaper and stuff displayed correctly.

However the following lines still appears in the journalctl:

plasmashell[1024]: Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.
plasmashell[1024]: If this Plasma has been installed into a custom prefix, verify that its D-Bus services dir is known to the system for the daemon to be activatable.

While it doesn’t seem to impact the proper functioning of the DE, would you have some clue to why the DBus service is still not recognized by the shell?

BTW, kactivitymanagerd doesn’t appear when I run qdbus:face_with_raised_eyebrow:


1 Like

The TL;DR version is that DBus looks for services in a particular location, and if you install the Plasma ones outside of that location, you need to tell DBus about it. Run plasma-workspace build directory]/login-sessions/ and to take care of this. If you care about what it’s doing under the hood, crack it open and give it a read.


I understand. But right now, I didn’t install Plasma and all its components in a custom location : everything is installed in /usr/

Huh, so do you see a bunch of KDE stuff in /usr/share/dbus-1/services/? If so, maybe the warning message is spurious.

Precisely… moreover, the process is running (I can see kactivitymanagerd when I do ps aux), but not when I do qdbus… odd.

1 Like