Black screen when trying to unlock screen

after previous update, i have problem. when i left a device untouched for a few minutes it will turn off screen to save energy, as i set here:
image

when i try to turn on screen it seems to work, but after i enter password it just shows black screen with cursor, nothing seems to work.

this logs when i entered lock screen:

Nov 21 20:31:57 archlinux kwin_x11[1376]: kwin_core: XCB error: 3 (BadWindow), sequence: 35176, resource id: 14680111, major code: 129 (SHAPE), minor code: 6 (Input)
Nov 21 20:31:59 archlinux kscreenlocker_greet[19699]: Qt: Session management error: networkIdsList argument is NULL
Nov 21 20:31:59 archlinux kscreenlocker_greet[19699]: kf.kirigami: Failed to find a Kirigami platform plugin
Nov 21 20:32:00 archlinux kscreenlocker_greet[19699]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/VirtualKeyboard.qml:8:1: module "QtQuick.VirtualKeyboard" is not installed
Nov 21 20:32:00 archlinux kscreenlocker_greet[19699]: libpng warning: iCCP: known incorrect sRGB profile
Nov 21 20:32:00 archlinux kscreenlocker_greet[19699]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/lockscreen/MediaControls.qml:82:9: QML Image: Blocked request.
Nov 21 20:32:08 archlinux dbus-daemon[674]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.293' (uid=1000 pid=19699 comm="/usr/lib/kscreenlocker_greet --immediateLock --gra")
Nov 21 20:32:08 archlinux dbus-daemon[674]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.

this after i entered lock screen, waited for a few minutes for screen to turn off, then turned it on, and logged in, and it showed black screen:

Nov 21 20:57:43 archlinux plasmashell[1426]: org.kde.plasma.notifications: Trying to replace notification with id 1811 which doesn't exist, creating a new one. This is an application bug!
Nov 21 20:57:43 archlinux plasmashell[1426]: Could not find the Plasmoid for Plasma::FrameSvgItem(0x55856370e420) QQmlContext(0x55855fe04290) QUrl("file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml")
Nov 21 20:57:43 archlinux plasmashell[1426]: Could not find the Plasmoid for Plasma::FrameSvgItem(0x55856370e420) QQmlContext(0x55855fe04290) QUrl("file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml")

what are your sleep/hibernate settings?

is that really matters?, i don’t put it into hibernation/sleep i just display to turn off but device itself not going to sleep

after some investigation i found that kscreenlock process is using 980 mb of ram, is that even normal? It seems problem is somewhere with kscreenlock i tried entering password and as always i see black screen, but then i killed kscreenlock while i’m seeing black screen, it opened another lock screen, i entered password again and i got everything restored, it seems like kscreenlock causing this black screen not plasma itself

i also found that screen energy saving is not only problem, even if i turn off this setting wait for a couple of minutes it be same black screen.

Does the problem go away if you install the distro package containing the QtVirtualKeyboard QML module?

Do you have multiple monitors?

Fixed by disabling video lockscreen, seems to be it causing black screen