Black screen with cursor after updating KDE Neon to Plasma 6

As the title says, after doing a standard update with discover to Plasma 6, when I log into my PC there is only a black screen with a cursor on it. I can still launch apps by keyboard shortcuts or from the terminal, but the desktop itself seems to be missing. I tried going to the TTY and updating the system once again through there, but after running “sudo pkcon update” it returns the following:

Fatal error: The following packages have unmet dependencies:
  plasma-desktop: Depends: plasma-desktop-data (= 4:5.27.10-0xneon+22.04+jammy+release+build47)

I tried installing the package it said was missing, but it returns the same error. If it helps in any way, I do not have a Nvidia GPU.

See other threads, please - and this might have been already fixed with the latest updates for KDE neon

I have exactly the same problem, after a usual update a few days ago plasma 6 was installed on my kde neon. In my NVIDIA based laptop now I have a black screen with cursor after login.
I think my neon version is the latest stable (based on ubuntu 22.04).
I found a partial workaround to enter my desktop:

  • boot my device until login screen
  • CTRL+F4 to swtich to a non-graphical console login
  • insert my username and password to enter a bash non-graphical shell
  • execute the shell command “startx”

This way I can open my dekstop session. But the problem needs a fix.

It’s a known issue. Try running the following in the teminal

sudo apt autoremove
sudo pkcon refresh
sudo pkcon install libdecor-0-0
sudo pkcon install libsdl2-2.0-0
sudo pkcon install plasma-desktop
sudo pkcon install plasma-desktop-data
sudo reboot

This is a proposed solution that you can find in reddit.

4 Likes

That worked, thank you.

Sometimes installing of libdecor-0-0 is not possible because of tons of unresolveable depencies. If that situation occurs, this command can help:
sudo pkcon install libdecor-0-0 libsdl2-2.0-0 plasma-desktop plasma-des
ktop-data --allow-reinstall
(I had to remove plasma settings files after that to avoid segfaulting plasmashell, but it worked properly then).

2 Likes

in my case (before the above workaround was available) I had to manually remove the wine32:i386 package.

In case of broken packages, synaptic can provide a good insight on what needs to be removed. I guess it calculates dependencies in a different way. So you just run synaptic, try to update the broken package and see with what proposal it comes up. You don’t proceed however with that proposal because it will probably break your system in an unexpected way. You just use what it suggests as an indication on what might be the cause of the issue.

Installing those packages didn’t work for me as they were already installed.
The only way by which I could temporarily solve the problem was uninstalling the nvidia drivers (tried versions 440 and 545) and using the opensource xorg nouveau driver instead.

In my case CTL F4 does nothing.
Any other idea to get to a fix?

I think he meant Ctrl+Alt+F4

Well, it actually probably depends on your system… So it might also be something else.