Blank/Missing Sound Settings

I’m using Debian 12 with Plasma 5.27.5, which I’ve installed normally using tasksel(8), albeit some time after initial set up, but everything is working correctly. Except for sound.

When I plugged in my USB speakers, I noticed that they weren’t being recognised, so I had a look at the audio settings, but turns out they’re entirely missing.

What gives? Do I need to manually install something? The speakers themself are being recognised and listed by using lsusb.

what is the output of inxi -A

CPU: 8-core AMD Ryzen 7 PRO 4750U with Radeon Graphics (-MT MCP-)
speed/min/max: 1437/1400/1700 MHz Kernel: 6.1.0-11-amd64 x86_64
Up: 102d 6h 25m Mem: 4732.7/15208.2 MiB (31.1%)
Storage: 476.94 GiB (17.9% used) Procs: 347 Shell: Bash 5.2.15 inxi: 3.3.26

Thanks for the help:)

I would think you missed the audio packages. Try installing the pipewire package should get them. The section of my Bookworm install file where I did it.

Needed to install it first.

root@8400:~# apt install pipewire
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libpipewire-0.3-modules pipewire-bin pipewire-media-session
The following NEW packages will be installed:
  libpipewire-0.3-modules pipewire pipewire-bin pipewire-media-session
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 997 kB of archives.
After this operation, 5,309 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 bookworm/main amd64 libpipewire-0.3-modules amd64 0.3.56-1 [517 kB]
Get:2 bookworm/main amd64 pipewire-bin amd64 0.3.56-1 [308 kB]
Get:3 bookworm/main amd64 pipewire amd64 0.3.56-1 [14.9 kB]
Get:4 bookworm/main amd64 pipewire-media-session amd64 0.4.1-3 [156 kB]

Run these three commands as your regular user (not as root):

// Check for new service files with:
systemctl --user daemon-reload
// Disable and stop the PulseAudio service with:
systemctl --user --now disable pulseaudio.service pulseaudio.socket
// Enable and start the new pipewire-pulse service with:
systemctl --user --now enable pipewire pipewire-pulse

Needed the pipewire-pulse for the last command to work and no need to copy the services above.

root@8400:~# apt install pipewire-pulse
Building dependency tree... Done
Reading state information... Done
The following additional package will be installed:

You can check which server is in use by, as your regular user, running:

LANG=C pactl info | grep '^Server Name'

If it's using PipeWire, the server name will be.

zeus@8400:~$ LANG=C pactl info | grep '^Server Name'
Server Name: PulseAudio (on PipeWire 0.3.56)

The inxi -A on my current install.

zeus@9600k:~$ inxi -A
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Device-2: Sonix GENERAL WEBCAM type: USB driver: snd-usb-audio,uvcvideo
  Device-3: C-Media CM106 Like Sound Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Griffin iMic type: USB driver: snd-usb-audio
  Sound Server-1: ALSA v: k6.2.0-39-generic running: yes
  Sound Server-2: PipeWire v: 0.3.48 running: yes

Edit: I would add now I think more about it. The pipewire install was necessary to get rid of that garbage pulse audio which will reliably cause a hard lockup requiring pushing the power button to resolve. When anything requiring sound is played like music or a video file on my machine. It was installed by choosing the KDE option when using the netinstall.iso file while choosing nothing else but the standard utilities and ssh to be installed. Then the switch to pipewire was made in that section of the notes.

I noticed that I used accidentally inxi -a, not -A earlier, oh well.
In any case, installing pipewire manually did the trick. I had installed pulse audio, but that doesn’t seem to have worked. thank you lots:)

You are welcome, good to read you got it sorted and have your sound working.

1 Like

so if you installed KDE via a metapackage please report a bug for the Debian people. pipewire should be installed along.

“so if you installed KDE via a metapackage please report a bug for the Debian people. pipewire should be installed along.”

No the pipewire does not get installed by default that piece of junk pulse audio does. You need to go out of your way like I did to get pipewire installed.

And here is the page from the Debian Wiki how to “officially” install Pipewire :

1 Like