Bluetooth Disabled But Still Showing Icon In Toolbar

I’m running the KDE Neon User Edition with all the recent updates applied. I do not use anything that requires Bluetooth so I deactivated it from automatically starting at start up. However, the Bluetooth icon still shows after I restart my computer. But when I look at my settings it shows it is not enabled and not running. In the meantime, I edited the toolbar settings to disable the Bluetooth icon from showing at all instead of “Show when applicable”.

How did you deactivate Bluetooth?

On my system, with the default setting of the Bluetooth icon (“Show when applicable”), if the controller is turned off (for example by the widget’s “enabled” switch) then the icon goes immediately to the overflow and will not return when the system is restarted (until I enable the controller again using the widget or bluetoothctl power on).

1 Like

I think the bigger issue with the bluetooth applet is that there is no button to enable bluetooth anymore. It can be disabled from the applet, but to enable it one must either go into the system settings or right click the applet. The on / off switch should not disappear when bluetooth is switched off.

That doesn’t seem to be correct - if I disable Bluetooth using the switch in the applet, the applet turns into a message that “Bluetooth is disabled” and there’s a bit button to enable it again:


It is true that with the default setting, after you turn off Bluetooth from the applet and close the applet popup, then the system tray icon is no longer visible in the notification area, so you can’t click it to re-open the applet popup - but the icon is in the overflow area and you can just open the overflow and access it from there.

Interesting. I have no such button. That’s probably a theme issue… the one I’m using probably has not been updated for Plasma 6. It did have such a button under Plasma 5 tho.


I don’t see how this could be a theme issue - but its easy to check: just change to the default theme and see if the problem solves itself. If not - I expect that the widget hides the “enable” button if it doesn’t think it can enable the adapter - which shouldn’t be the case if the widget could disable the adapter.

If this is indeed not a theme issue - I suggest opening a bug report about it at

yup, definitely not the theme… just tried a bunch of different ones… all the same result.

EDIT: Not sure what happened, but I suddenly have an “Enable” button. Apologies for hijacking the thread.