Bluetooth won't enable under KDE Plasma


I am a Linux/Fedora/KDE newbie, so please be kind. I recently installed Fedora 39 and am running KDE Plasma under Wayland. I’ve encountered two issues: the system cannot find either the wi-fi or Bluetooth adapters. I’ve given up trying to fix the wi-fi as I’ve read that the Fedora 39 kernel does not yet support the MediaTech 7902 adapter. Is this also the case with the Bluetooth? Neither trying to enable the Bluetooth under settings nor using ‘sudo systemctl restart bluetooth’ does anything.

Here are some of my status readouts:

me@fedora:/$ sudo service bluetooth status
Redirecting to /bin/systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: enabled)
    Drop-In: /usr/lib/systemd/system/service.d
     Active: active (running) since Mon 2024-04-22 12:42:27 EDT; 15min ago
       Docs: man:bluetoothd(8)
   Main PID: 4878 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 8522)
     Memory: 584.0K
        CPU: 40ms
     CGroup: /system.slice/bluetooth.service
             └─4878 /usr/libexec/bluetooth/bluetoothd --experimental

Apr 22 12:42:27 fedora systemd[1]: Starting bluetooth.service - Bluetooth service...
Apr 22 12:42:27 fedora bluetoothd[4878]: Bluetooth daemon 5.73
Apr 22 12:42:27 fedora systemd[1]: Started bluetooth.service - Bluetooth service.
Apr 22 12:42:27 fedora bluetoothd[4878]: Starting SDP server
Apr 22 12:42:27 fedora bluetoothd[4878]: Bluetooth management interface 1.22 initialized

me@fedora:/$ rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

me@fedora:/$ hciconfig
hci0:   Type: Primary  Bus: USB
        BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
        RX bytes:0 acl:0 sco:0 events:0 errors:0
        TX bytes:3 acl:0 sco:0 commands:1 errors:0

Using ‘hciconfig up’ does nothing. I’ve tried creating /etc/systemd/system/bluetooth.service.d (it didn’t exist) and creating the file ‘override.conf’ in it with the code:

ExecStart=/usr/libexec/bluetooth/bluetoothd --experimental

I’ve also tried using pacman to install bluez. Still didn’t do anything. Does anyone have any ideas?

Thank you.

Just run the dmesg command and look at the output (warning: it will be long) for any errors related to missing firmware. I believe this is the cause and if your adapter is supported by linux, there will be an error message about it in output of dmesg

1 Like

Thanks for responding. The only error I found was this:

Bluetooth: hci0: Opcode 0x0c03 failed: -110

A search showed no messages relating to missing firmware. Is this the problem?

I has same problem with bluetooth (not same error) but figured out it was because my PC was not set to “visible” in bluetooth settings.

right click bluetooth icon → configure bluetooth → configure → Visible
This checkbox resets every time your turn off\on bluetooth so keep that in mind.

I also had to sudo systemctl restart bluetooth

You might also wan to enable and start bluetooth with systemctl

Can you upload the whole output of dmesg to pastebin or some similar service?

Edit: Oh! Just forget it. Seems like it is not supported in linux

maybe try with the latest kernel? :roll_eyes:

“Configure Bluetooth” only has one setting for me: an Enable button, but it doesn’t do anything when clicked.

Edit: Oh! Just forget it. Seems like it is not supported in linux

Yeah, that’s why I gave up on the wifi and just bought a USB adapter. But isn’t the Bluetooth a different adapter? My current kernel is 6.8.6-200.fc39.x86_64.

No! Wifi and bluetooth comes together in the same chipset.

Well! That would be the reason. But why isn’t my USB wifi adapter also functioning for Bluetooth, then? Or is the external adapter for wifi only?

Yeah! That’s not the case for all usb adapters. You can find usb adapters that function both as wif and bluetooth, but not all usb adapters do so.

1 Like

I see. Well, I greatly appreciate the support. I hope the MT7902 is supported soon. It sucks not being able to use the wireless capabilities of this new device. Thank you!