Boot broken after Discover update

After Discover update, I can’t open GUI.
Then, my display show “end Kernel panic - not syncing : No working init found. Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance.” on CUI.

I tried to move on old Kernel. But I can’t open it.

How can I fix it? Please tell me.
Thank you!

My Environment

  • CPU: Intel 4th
  • GPU: Intel (CPU inside)
  • OS: KDE Neon 5.27
  • Kernel: 6.2.0-39

I can fix it!!
Thanks for KDE community users and Reddit community users.

What did the problem caused

Might Discover download some files for update corrupted during download.

How to fix it

  1. Boot to use 5.2.0-37(reco) (I couldn’t boot it yesterday, but I can it today.)
  2. Fix fsck and grub. (Might not be necessary.)
  3. Update Discover. (Might not be necessary.)
  4. sudo apt update, sudo apt full-upgrade and sudo pkcon update on your terminal. (Might not be necessary.)
  5. Try: (sudo update-initramfs -u -k all and update-grub on your terminal.)
  6. Shatdown and boot to use 5.2.0-39
  7. You can use KDE neon!!

Things that have been tried and failed

Memo in My mother language (same contents above) / 日本語でのメモ






  • LiveUSB(Linux Mint)から起動して、ドライブをマウントし、その後に修復を試そうとしたが無理だった。(この時は6.2.0-37(reco)が動くことを知らなかったので、外部からどうにかするしかないと考えていた。)私はLinux filesystemをマウントしたが、Linux swapのほうをマウントするとこの方法でも直るのかもしれない。