Boot very slow, today [solved]

Today (this morning) I noticed that the boot is become very slow (several minutes), even my pc is new (16gb of ram, AMD Ryzen 7 5700G).
The command systemd-analyze blame
gave this output

3.115s NetworkManager-wait-online.service
1.980s fwupd-refresh.service
1.928s fwupd.service

But removing that services doesn’t fix the problem, such as removing nmbd.service.

I suppose that this new problem is caused by either a change in fstab (added swap partition), or a failed installation of kubuntu.
Indeed I tried to install Kubuntu without modifying the EFI partition (installing the boatloader within Kubuntu partition). Maybe the Kubuntu installer modified swap partitions?

EDIT

Kubuntu modified the UUID of one of the two swap partitions.

Indeed, now, fixing that UUID in fstab (with the correct one), the boot is less than 5 seconds.
Solved!

After update to Plasma 6, my system booting very slow to (desktop after entering password).

/etc/fstab:

UUID=EC48-40E9                            /boot/efi      vfat    defaults   0 2
UUID=f91fd627-0c14-4151-a0b5-f748226a3093 /              ext4    defaults   0 1
UUID=3be03a4b-f720-4404-9e2c-c065f4d3594b swap           swap    defaults   0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

systemd-analyze blame:

2.408s fwupd.service
1.842s NetworkManager-wait-online.service
1.582s smartmontools.service
1.047s snapd.service
 831ms udisks2.service
 580ms snapd.seeded.service
 482ms plymouth-quit-wait.service
 481ms plymouth-quit.service
 414ms systemd-journal-flush.service
 381ms gpu-manager.service
 377ms e2scrub_reap.service
 348ms dev-sdd2.device
 345ms neon-apt-mark-kernels-auto.service
 307ms networkd-dispatcher.service
 306ms dev-loop1.device
 305ms dev-loop2.device
 295ms dev-loop6.device
 293ms dev-loop5.device
 289ms dev-loop3.device
 282ms dev-loop4.device
 248ms accounts-daemon.service
 240ms user@1000.service
 226ms boot-efi.mount
 210ms polkit.service
 207ms power-profiles-daemon.service
 207ms dev-loop0.device
 187ms avahi-daemon.service
 180ms systemd-udev-trigger.service
 180ms NetworkManager.service
 161ms lvm2-monitor.service
 159ms snapd.apparmor.service
 152ms ModemManager.service
 151ms switcheroo-control.service
 145ms thermald.service
 145ms systemd-logind.service
 143ms wpa_supplicant.service
 133ms systemd-fsck@dev-disk-by\x2duuid-EC48\x2d40E9.service
 130ms systemd-resolved.service
 127ms smbd.service
 112ms secureboot-db.service
 112ms nmbd.service
 101ms systemd-journald.service
  89ms systemd-timesyncd.service
  86ms upower.service
  80ms rsyslog.service
  79ms apparmor.service
  68ms grub-common.service
  67ms systemd-modules-load.service
  63ms dev-disk-by\x2duuid-3be03a4b\x2df720\x2d4404\x2d9e2c\x2dc065f4d3594b.swap
  63ms systemd-udevd.service
  61ms keyboard-setup.service
  58ms cups.service
  48ms fwupd-refresh.service
  45ms modprobe@drm.service
  43ms i2p.service
  36ms systemd-tmpfiles-clean.service
  36ms packagekit.service
  24ms snapd.socket
  24ms grub-initrd-fallback.service
  23ms plymouth-start.service
  19ms alsa-restore.service
  19ms systemd-tmpfiles-setup.service
  17ms systemd-binfmt.service
  16ms dev-hugepages.mount
  16ms snap-core22-1122.mount
  16ms dev-mqueue.mount
  15ms snap-core22-1033.mount
  15ms sys-kernel-debug.mount
  15ms systemd-tmpfiles-setup-dev.service
  15ms snap-bare-5.mount
  14ms snap-gnome\x2d42\x2d2204-141.mount
  14ms sys-kernel-tracing.mount
  14ms systemd-sysctl.service
  13ms snap-gtk\x2dcommon\x2dthemes-1535.mount
  13ms systemd-sysusers.service
  12ms plymouth-read-write.service
  11ms kmod-static-nodes.service
  11ms user-runtime-dir@1000.service
  10ms systemd-remount-fs.service
  10ms snap-mysql\x2dworkbench\x2dcommunity-12.mount
   9ms modprobe@configfs.service
   9ms systemd-update-utmp.service
   9ms proc-sys-fs-binfmt_misc.mount
   8ms snap-snapd-20671.mount
   8ms systemd-random-seed.service
   7ms modprobe@fuse.service
   7ms nvidia-persistenced.service
   6ms console-setup.service
   6ms openvpn.service
   5ms systemd-update-utmp-runlevel.service
   5ms systemd-user-sessions.service
   4ms rtkit-daemon.service
   3ms setvtrgb.service
   3ms tmp.mount
   3ms ufw.service
   2ms modprobe@efi_pstore.service
   2ms sys-kernel-config.mount
   2ms sys-fs-fuse-connections.mount
  32us blk-availability.service

Result of blkid command and fstab strings UUID’s the same, but EFI partition UUID’s is different.

How to fix it? Change UUID of EFI partition?
P. S. OS: KDE Neon Testing Edition

I can’t help you, sorry. But I don’t see a reason to modify the UUID of efi partition (potentially very dangerous).
Maybe it would be better if you open a new thread, because this one is marked as solved :slightly_smiling_face: