Breeze-plymouth decrypt password missing bullet font

I’ve been scratching my head over this for days and couldn’t find any solution.
When I use breeze-plymouth theme there are squares displayed instead of bullet points on decrypt prompt.

So I figured “it’s missing font”, I look into the .plymouth file - no font declaration there - it should be there i think?
Then I looked into the script and gotcha, it’s Noto Sans font.

I add the font to mkinitcpio.confFILES’ array and rebuild. And… it doesn’t work.
Retried but I added everything in /usr/share/fonts/noto/* and it still doesn’t work.
I’ve also tried adding “Font=Noto Sans” to breeze.plymouth file with no success (so that /usr/lib/initcpio/install/plymouth can pick it up).

I verified that the files are there with lsinitcpio.
I have all noto fonts packages installed.

This is screenshot of the issue I forgot to add:

I’ve had the same issue, what fixed it for me was appending
'/usr/lib/plymouth/label-pango.so' to map add_binary in /usr/lib/initcpio/install/plymouth and then running mkinitcpio -P

Thanks for pointing me in the right direction - I added /usr/lib/plymouth/label-pango.so to BINARIES array in /etc/mkinitcpio.conf and it works!
I believe this is a way better approach than modifying pacman tracked file!

Thanks a lot for the solution! Any ideas why this is not configured by default?