Broken maximize button

So, after some time using KDE I noticed my maximize button suddenly stopped working. I have no clue why. I restarted my PC multiple times and tried to remove and add back the maximize button through the system settings but it just does not work:

Shortcuts to maximize don’t work either. I used to have a different theme on and it would show the button but it wouldn’t do anything when clicked.

I have some tiling scripts installed like Krohnkite and Bismuth, they were never activated at the same time. Currently all scripts are disabled and I restarted multiple times without any scripts.

Neofetch info:

OS: KDE neon 5.27 x86_64
Host: Latitude E6540 00
Kernel: 5.19.0-43-generic
Uptime: 8 hours, 51 mins
Packages: 2394 (dpkg), 56 (flatpak)
Shell: bash 5.1.16
DE: Plasma 5.27.5
WM: kwin
Theme: [Plasma], Breeze [GTK2/3]
Icons: [Plasma], breeze-dark [GTK2/3]
Terminal: konsole
CPU: Intel i7-4700MQ (8) @ 3.400GHZ
GPU: Intel 4th Gen Core Processor
Memory: 3376MiB / 7853MiB

If you have any clue whats wrong or what would make it easier for anyone to identify the issue please let me know. Thanks for any help in advance.

In ~/.config, what are the contents of kwinrc?

Particularly important is the [org.kde.kdecoration2] group, which should contain the key ButtonsOnRight if you have changed anything. If it doesn’t exist, it’s using defaults and the problem is even more bizarre. if it exists, remove it.

I found it! Super sorry for the late reply. Do I delete the whole [org.kde.kdecoration2] group or just ButtonsOnRight?

Take a backup of the config file and delete just the ButtonsOnRight then logout and back in.

Did. It didn’t work. I restarted my PC fully and it still wouldnt show the maximize button. As before the maximize button is showing on Chromium, but it still doesn’t work. What now?