Broken system after update

Hi, yet another broken system due to package dependency issues after updating my KDE Neon User system.

When booting it just shows some weird login screen which is entirely unresponsive and a lot of red error messages complaining about missing qml files.

I tried running pkcon upgrade manually, but that spits out the following

Fatal error: Error while installing package: trying to overwrite '/usr/share/locale/ca/LC_MESSAGES/libphonon_qt.qm', which is also in package libphonon4qt5-data 40xneon+22.04+jammy+release+build3.all

This is quite unhelpful as it doesn’t say which package it fails to install, and turns out pkcon --verbose is completely useless in this regard…

Moving on, I tried running some apt commands which didn’t work because my system was broken and it suggested running apt --fix-broken install which I tried:

sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies...Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
The following packages were automatically installed and are no longer required:
  breeze-icon-theme kaccounts-providers kde-style-oxygen kde-style-oxygen-qt5 kuserfeedback-doc kwayland-data kwin-decoration-oxygen
  kwin-wayland-backend-drm libavif13 libcolorcorrect5 libflashrom1 libftdi1-2 libhyphen0 libilmbase25 libkdecorations2private9
  libkf5dbusaddons-bin libkf5iconthemes-bin libkf5jsapi5 libkf5plasmaquick5 libkf5screen-bin libkf5style5 libkf5su-bin libkf5su-data
  libkf5su5 libkf5xmlgui-bin libkfontinst5 libkfontinstui5 libkpipewire5 libkwinxrenderutils13 libllvm13 libnotificationmanager1
  libopenexr25 liboxygenstyle5 liboxygenstyle5-5 liboxygenstyle6 liboxygenstyleconfig5-5 liboxygenstyleconfig6
  libplasma-geolocation-interface5 libpoppler124 libpoppler126 libpoppler127 libqt5quickshapes5 libqt5sensors5 libqt5webkit5
  libtaskmanager6 libweather-ion7 libwoff1 libzxingcore1 linux-generic-hwe-20.04 linux-headers-5.15.0-48 linux-headers-5.15.0-48-generic
  linux-headers-5.15.0-52 linux-headers-5.15.0-52-generic linux-headers-5.15.0-56 linux-headers-5.15.0-56-generic linux-headers-5.15.0-58
  linux-headers-5.15.0-58-generic linux-headers-5.15.0-67 linux-headers-5.15.0-67-generic linux-headers-5.15.0-69
  linux-headers-5.15.0-69-generic linux-headers-5.15.0-73 linux-headers-5.15.0-73-generic linux-headers-5.15.0-76
  linux-headers-5.15.0-76-generic linux-headers-5.15.0-79 linux-headers-5.15.0-79-generic linux-headers-5.19.0-35-generic
  linux-headers-5.19.0-38-generic linux-headers-5.19.0-43-generic linux-headers-5.19.0-46-generic linux-headers-generic-hwe-20.04
  linux-hwe-5.19-headers-5.19.0-35 linux-hwe-5.19-headers-5.19.0-38 linux-hwe-5.19-headers-5.19.0-43 linux-hwe-5.19-headers-5.19.0-46
  linux-image-5.15.0-48-generic linux-image-5.15.0-52-generic linux-image-5.15.0-56-generic linux-image-5.15.0-58-generic
  linux-image-5.15.0-67-generic linux-image-5.15.0-69-generic linux-image-5.15.0-73-generic linux-image-5.15.0-76-generic
  linux-image-5.15.0-79-generic linux-image-5.19.0-35-generic linux-image-5.19.0-38-generic linux-image-5.19.0-43-generic
  linux-image-5.19.0-46-generic linux-image-generic-hwe-20.04 linux-modules-5.15.0-48-generic linux-modules-5.15.0-52-generic
  linux-modules-5.15.0-56-generic linux-modules-5.15.0-58-generic linux-modules-5.15.0-67-generic linux-modules-5.15.0-69-generic
  linux-modules-5.15.0-73-generic linux-modules-5.15.0-76-generic linux-modules-5.15.0-79-generic linux-modules-5.19.0-35-generic
  linux-modules-5.19.0-38-generic linux-modules-5.19.0-43-generic linux-modules-5.19.0-46-generic linux-modules-extra-5.15.0-48-generic
  linux-modules-extra-5.15.0-52-generic linux-modules-extra-5.15.0-56-generic linux-modules-extra-5.15.0-58-generic
  linux-modules-extra-5.15.0-67-generic linux-modules-extra-5.15.0-69-generic linux-modules-extra-5.15.0-73-generic
  linux-modules-extra-5.15.0-76-generic linux-modules-extra-5.15.0-79-generic linux-modules-extra-5.19.0-35-generic
  linux-modules-extra-5.19.0-38-generic linux-modules-extra-5.19.0-43-generic linux-modules-extra-5.19.0-46-generic oxygen
  oxygen-cursor-theme phonon4qt5 plasma-desktop-data plasma-theme-oxygen qdbus-qt5 qml-module-org-kde-activities qml-module-org-kde-breeze
  qml-module-org-kde-kaccounts qml-module-org-kde-kconfig qml-module-org-kde-kholidays qml-module-org-kde-kwindowsystem
  qml-module-org-kde-pipewire qml-module-org-kde-solid qml-module-qtquick-shapes qtchooser signon-kwallet-extension
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  breeze breeze-cursor-theme kde-config-screenlocker kscreen layer-shell-qt libkscreenlocker5 libpam-kwallet-common libpam-kwallet5
  libpam-kwallet6 plasma-desktop plasma-workspace plasma-workspace-wayland qt6-phonon qt6-sensors
Recommended packages:
The following NEW packages will be installed:
  libpam-kwallet6 qt6-phonon qt6-sensors
The following packages will be upgraded:
  breeze breeze-cursor-theme kde-config-screenlocker kscreen layer-shell-qt libkscreenlocker5 libpam-kwallet-common libpam-kwallet5
  plasma-desktop plasma-workspace plasma-workspace-wayland
11 upgraded, 3 newly installed, 0 to remove and 459 not upgraded
Need to get 0 B/92,4 MB of archives.
After this operation, 43,4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 726918 files and directories currently installed.)
Preparing to unpack .../qt6-phonon_4%3a4.12.0-0xneon+22.04+jammy+release+build10_amd64.deb ...
Unpacking qt6-phonon (4:4.12.0-0xneon+22.04+jammy+release+build10) ...
dpkg: error processing archive /var/cache/apt/archives/qt6-phonon_4%3a4.12.0-0xneon+22.04+jammy+release+build10_amd64.deb (--unpack):
 trying to overwrite '/usr/share/locale/ca/LC_MESSAGES/libphonon_qt.qm', which is also in package libphonon4qt5-data 4:4.11.1-4+22.04+jammy+release+build3
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I suppose I need to do what this[1] user tried and remove plasma entirely, but I’m just a casual pleb so don’t know how to go about doing that.

I’m assuming here my system is borked and it won’t just solve itself if I leave the system for a week or two and then run the update again? If so, any pointers as to how I can get things running again?

[1]: can’t post links, oh well

In the upgrade from 5 to 6 some files moved between packages and that’s not a good situation because when installing parts of the system (which happens during any upgrade - some parts are updated while other parts haven’t yet), you will get into a situation where you need to install a new package that has a file from a different older package that hasn’t updated yet - and as you can see, Apt hates that.

During Plasma 6 development, the Neon developers suggested setting Apt to automatically allow overwriting files from another package, but at this point it should have been stable and so it doesn’t make sense to allow this globally.

For now - to move forward - you should run apt --fix-broken -o Dpkg::Options::="--force-overwrite" install to get the conflicting packages to install, then do apt full-upgrade -o Dpkg::Options::="--force-overwrite" to update everything to the current state, then do apt autoremove --purge to delete the unneeded old packages.

Then when the dust settles down - see if you can get a working system, if not - ping here.