Broken Task Switcher after update to plasma 6

Hi, after updating to plasma 6 the thumbnail grid task swicher stoped working. On plasma 5 I had it installed as a add on becose it wasent included. Every time I try to use it it says: "The Window Switcher installation is broken, resources are missing.
Contact your distribution about this. "

When i tried different task swicher that i newly installed (the only one available) it worked fine. What should I do?

I had this same issue - it seems to be just that, if you’re using a custom task switcher, the upgrade breaks the connection to it. (I was using “mediumRoundedDark”.)

I just went into settings, chose the new “Large Icon” option, and it started working again. There’s a grid option, too, though.

1 Like

Only option I have there is thumbnail grid which is broken and then the nwely installed modern informative.

You can install kdeplasma-addons to get more options.

As I said before there is only one available. And I already installed so I have at least somthing, but I want to use thumbnail grid.

The package you have installed might be not the qt6/kf6 version, reinstalling it might help.

I don’t know your distro, can’t help more.

Ah, I was assuming you were on KDE Neon for some reason - sorry.

Yeah, KDE Neon’s implementation of KDE 6 comes with several by default, here:

But if you’re on something more bare bones maybe you don’t have as many options…?

By default I only have thumbnail grid.

What distro are you on?

I am on CachyOS. Which Is based on Arch.

I had the same issue on Arch. I had installed thumbnail grid on plasma 5 and it stopped working after updating to plasma 6. After checking journalctl for errors I found this:

kwin_tabbox: Component failed to load: QList(file:///home/username/.local/share/kwin/tabbox/thumbnail_grid/contents/ui/main.qml:4:1: module “org.kde.plasma.components” version 2.0 is not installed
import org.kde.plasma.components 2.0 as PlasmaComponents
^)

It seems like it is still trying to use the old thumbnail grid from plasma 5 which uses older libraries that are no longer in plasma 6.

Removing the thumbnail_grid folder given in the error path fixed the issue for me.

2 Likes

thank you! this worked for me too.

tldr; reinstall “kwin” package

Longer story: After another look through this issue I saw kwin package included in MRs - paru -Ql kwin confirmed that it includes tabbox/thumbnail_grid now (which is what I assume was meant by everyone saying that it’s now part of KDE - on the store it still says that it’s part of the kdeplasma-addons package).

I assume that this tabbox addon should live in ~/.local/share/kwin, but for some reason for me it was in /usr/share/kwin - perhaps installed it as root when starting out with KDE many moons ago.

1 Like