[Bug] Baloo File Search Folder Index

Hello there,

I am currently using Plasma 5.27.6 on Arch Linux. I have been facing a bug where if folder-specific indexing is set to “not indexed” and even after file search is set to disabled, Baloo still shows indexed the same folder and remembers this state even after reboots.

But I think that developers will be fixing this bug related to Baloo very soon.

This looks like 439403 – Folder specific configuration show multiple home directory rules that cannot be deleted

Edit… Maybe worked out how to include a reference to bugs.kde.org

This bug seems to still not have been resolved and still exists in KDE Plasma 5.27.6. I hope that @ngraham will take a look into this bug and that it will be fixed in the next releases.

I’m guessing you changed your
folder from “Indexed” to “Not indexed” in System Settings…

This seems to confuse things is you don’t have any other folders indexed. If you index, say, Documents and then set your home folder to “Not Indexed”, there seems to be no problem.

You can “factory reset” your indexing configuration by deleting your