Calamares fails to initialize, KDE neon developer edition

I’m on windows, trying to run the KDE Neon developer/unstable edition in VirtualBox. I downloaded the disk image from this link (as mentioned in this KDE article), but I get the following error when starting the vm and attempting to install the not-preview version of KDE unstable. Is there any way to fix this?


PS, if the image is too small, here’s the text:

Calamares Initialization failed

KDE neon can not be installed. Calamares was unable to load all of the configured modules. This is a problem with the way Calamares is being used by the distribution. The following modules could not be loaded:

  • users@users
  • users@users

Get the same error using the testing edition and development edition (from the website - h ttps://neon.kde.org/download (there’s a link limit for new users))

There was an upstream error in Calamares. I understand the problem has been sorted, but you will have to download the ISO again. For me the unstable version now installs fine.

Lots of luck!

Ok, I’ll try again. Thank you!

I’ve re-downloaded the developer image (which I believe is the one I want), but the version hasn’t changed and so Calamares still fails to initialize. Does only the unstable edition work? I was hoping I could use the image with pre-installed development libraries (because I had trouble installing them properly on Ubuntu (latest) and KDE (latest, I managed to break apt))

Do you want to run Neon as your daily driver desktop operating system? Are you an end user? Or do you want to contribute to developing and bug hunting for Plasma 6?

Either way, pinging @scarlettmoore so she can take a look.

I’d like to contribute (if I can, I wouldn’t be sure where to start), and I’ve tried to build the source for some packages (as described here) on different operating systems (as mentioned, Ubuntu and KDE neon (stable) in Virtualbox), and got some of it to build and run (namely, KCalc), but repeatedly got stuck when dependencies weren’t satisfied while building KDE Plasma and its dependencies, so I would like to use the development build.

(My host OS is Windows 10)

I will rebuild developer ISO

Please try the newest developer ISO

Sorry for the late reply, but Calamares seems to be working! I will try installing the system now, and post again (in a separate topic) if I encounter any other problems.
Thank you!