Cannot drag and drop any clip from project bin to timeline

OS: Fedora 38
Kdenlive: Tried both (23.04.0 flatpak, 22.12.3 Fedora rpm)

I cannot drag and drop any clip (be it title clip created or video clip) to the timeline. As soon as I start dragging the clip, there is a ban mark appears. This mark seems what I do is disallowed.

What am I doing wrong?

Thank you.

PS. It happened after upgrading to Fedora 38 and Kdenlive.

1 Like

Over at r/kdenlive there was a very similar question and one of the replies pointed at a problem with Qt on Fedora: Drag&Drop not working in Qt-Applications (#2715) · Issues · GNOME / mutter · GitLab

And just to make sure it is not the application try the appimage …

Thank you for your input. Tried appimage. Same problem.

So, it is a Qt problem on Fedora.

Thank you very much.

Same problem here on Ubuntu 23.04 and Kdenlive 23.04 with flatpak or appimage.

The timeline is completely locked and I cannot drag&drop anything.


1 Like

Hmm, I am using the 23.04 kdenlive appimage on Pop!_OS which is based on Ubuntu albeit 22.04

I think it is an issue with Gnome 44.

Same Problem! Can,’t work anymore!

Ubuntu 23.04


Work around:

  • select file in project bin
  • hit v

This will insert the file in timeline.

Attention: the new file cuts the File in timeline.

1 Like

Same problem on clean install Ubuntu 23.04. Cannot drag and drop ANYTHING to the timeline. Dragging effects doesn’t work either.

Makes using Kdenlive nearly impossible IMHO.

Both universe install and AppImage have the same problem. Older AppImage fails as well. I keep old versions around just in case something like this happens, but in this case its broken across the board.

Odd Work Around: Dragging directly from Gnome Files 44 into the Timeline (not the Project Bin) works. It was an accident that I even noticed, as that isn’t how I ever drop things on the Time Line.

Dragging from Project bin to Timeline - fails.
Dragging Effects to Timeline - fails.

Well, if that’s the case the issue is not with kdenlive but with the DE or the distro itself.

It looks like Ubuntu 23.04 broke something because ppl reporting these issues are in most if not even all cases on Ubuntu 23.04 …

Issue is something in KDenLive. Drag and Drop operations work in all my other apps, so it’s gotta get fixed in KdenLive.

Looks like the devs are already working on a fix (469029 – Cant Drag and Drop ANY Clips to Timeline related to 468962 – Clip on timeline changes identity/name, gets exchanged random).

I’ve tried a few daily builds and some really old builds, all do this.

Anyone know if DaVinci Resolv has this problem too? I need to edit some video soon and I need a solution that doesn’t involve downgrading my entire Linux distro so that this works again.

At the moment this problem not appears in UBUNTU 22.04.02 LTS. Works fine at the last Kdenlive version 23.04.0.

I found an easy solution (I’m using ubuntu 23.04):

Go to: mutter package : Ubuntu
And download the mutter 44.2 version, which includes the fix.

These are the packages needed for 64bit:

  • gir1.2-mutter-12_44.2-0ubuntu1_amd64.deb
  • libmutter-12-0_44.2-0ubuntu1_amd64.deb
  • mutter-common_44.2-0ubuntu1_all.deb
  • mutter-common-bin_44.2-0ubuntu1_amd64.deb

Then open up a terminal and install them with:

sudo dpkg --install gir1.2-mutter-12_44.2-0ubuntu1_amd64.deb libmutter-12-0_44.2-0ubuntu1_amd64.deb mutter-common_44.2-0ubuntu1_all.deb mutter-common-bin_44.2-0ubuntu1_amd64.deb

Logout / Restart system. You can now edit as normal again.
This also solved not being able to drop effects unto the tracks.

1 Like