Cannot select keyboard layout

Hello, am having issues adding a new keyboard layout, it worked before then something updated and now the keyboard layout im trying to add (czech, slovak, german (us)) but it says it’s BQN instead of US and when pressing preview it says

Keycodes above 256 (e.g. ) are not supported by X and are ignored
Error: No Symbols named “cz_sk_de” in the include file “bqn”
Abandoning symbols file “(null)”

which makes sense because there is no BQN layout with this variation that exists, it used to work but stopped after some updates, I’m not sure which update it was because I tried downgrading the xkeyboard related packages and the issue persisted.

Hi, as a friend of mine and me both were experiencing the same issue (for a different layout variant), I have created a bug report for this issue, it has the ID 489975.

For now, a workaround to this is to manually edit the layout and variant configuration (in ~/.config/kxkbrc). I posted my workaround config in the bug report post aswell.