Cannot split subtitles (24.05.0 linux appimage)

Project > Subtitles > Edit Subtitle Tool
Split Subtitle at cursor position (scissor icon)

This doesn’t seem to work. I have tried this with an older project as well as a brand new project with just one piece of subtitle text added. No split occurs.

System: Kernel: 6.6.11-amd64 [6.6.11-1~mx23ahs] arch: x86_64 bits: 64 compiler: gcc v: 12.2.0 parameters: BOOT_IMAGE=/boot/vmlinuz-6.6.11-amd64 root=UUID=<filter> ro Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm v: 4.18.0 vt: 7 dm: LightDM v: 1.26.0 Distro: MX-23.2_ahs_x64 Libretto October 15 2023 base: Debian GNU/Linux 12 (bookworm)

Drives: Local Storage: total: 931.51 GiB used: 510.66 GiB (54.8%) SMART Message: Unable to run smartctl. Root privileges required. ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S1000G size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: SBM02103 temp: 27.9 C scheme: MBR

Do you have the subtitle “clip” you want to split selected? This works for me just the same as it does for any other clip with the 24.05.0 appimage, both using the razor tool (scissor icon) and mouse, and the keyboard shortcut for it. I get two clips with the same text split at the cursor on the subtitle track.

edit: at the risk of maybe saying something “obvious” here, if you use the “scissor icon”, that just converts your mouse pointer into being the razor tool - so you still need to actually click at each place you want to make a cut - it doesn’t automatically make a cut at the pre-existing current cursor position (like the keyboard shortcut will, regardless of the current mouse tool mode).

Yes, the subtitle clip is selected (it shows an orange border) with the white line (play head) where I want to cut it. Only rarely does the cut actually happen. I can upload a video somewhere if you like, to prove I am not going crazy. I have spent at least a couple of hours trying to fix this, but can’t.

Just to make it perfectly clear (and not confuse it with the other scissor icon), I am using the scissor icon which, when moused-over, shows the text Split subtitle at cursor position. Part of the Subtitles section in the bottom-right of my screen.

I have tried an existing project as well as a brand new project. Only very rarely will the cut happen. When trying the Scissor Tool (x) it works fine but not the Scissor button in the Subtitles section.

I didn’t doubt you’d seen what you said :slight_smile: I’m in the middle of subtitling a large project right now, so if there was a problem I hadn’t seen somewhere I was interested in understanding it and seeing it gets fixed.

And you are quite right, the “split subtitle” button at the bottom of the subtitles tab indeed does nothing for me too. I pretty much never use those, so had forgotten it was even there. (Usually to duplicate a subtitle I just copy and paste with a couple of right clicks in the timeline).

If there isn’t already a report of this, please make one here:
https://bugs.kde.org/buglist.cgi?bug_status=__open__&list_id=1248416&order=Importance&product=kdenlive