Cant boot Neon Testing live USB

I seem to get to where it loads the nouveau driver and then stalls out with a grey screen. Attempting to boot the live usb with safe graphics results in a brief appearance of the cursor on a black screen, then back to a prompt then back to a cursor as if it is crashing and looping.

I tried waiting it out for a few minutes in both the normal and safe graphics modes, but nothing changed.

I have tried a couple different ISO versions over the past two weeks.

I use dual Nvidia GPUs with multiple displays on an MSI X470 and Ryzen 5 2600x with 16gb of Kingston HyperX 3200 on a desktop PC, not laptop. Bios firmware is up to date.

Is the new testing ISO defaulting to Wayland? Might this be the issue? My machine does not like wayland.

Have the same problem. I have had this problem with Debian, Mint, Cinnamon.
I have a Nvidia RTX4060 and the nouveau driver report “unknown chip set”
On the other installations, it appears it partially works but cannot handle my monitor 3840x2160, but I was able to boot to the root terminal using safe graphics mode, then I was then able to load the nvidia driver.

On neon I don’t see any difference between the normal boot and the safe graphics boot option. Does the same thing, just seems to be stuck in a reset graphic loop.
When I have time I will have to learn about grub and edit the grub at boot time.

Hello, I’m not 100% sure it is the same exact problem, but you can try the way I solved mine

With a card that new, you really should use the nvidia drivers.

I have said this multiple times in other threads, and nobody seems to oppose me so I have a feeling I am correct.

Wayland does not accept “half-assed” configs like x11 did.
You need to configure nvidia correctly for x11 so xwayland can use the nvidia configs correctly.

As for noevau, again, this card is VERY new.

With nvidia drivers, if I revert to “default config files” (or just removes them) on plasma 5, it shows this exact behavior when trying to use wayland.
And if I boot with a live usb and choose to use noevau, 10% of the times I get a black screen with only a mouse pointer instead of a desktop.

And with correct config I mean configure everything correct.
Nvidia config files, kernel modules, hooks, configure grub etc etc etc.

Thanks for the reply @MaxCube128
Yes, that is the solution which worked for me.

Thank you for your reply @bedna
I think you are spot on. The solution above does the trick.
The way the nouveau driver is “derived” (kudos maximus to the nouveau guys), it will probably take some time to keep up with the newer cards.

Thanks that got the live USB working in both normal and safe modes.