Can't discover printer

  1. I input the password into
  2. Yet this merely causes


remains identical regardless.

YaST (xdg-su -c '/sbin/yast2 printer') states

but I’m unsure of how to verify that this isn’t the cause.

Any guesses about whether I’m doing anything wrong?

Disable your firewall and try again maybe?

1 Like


  1. Enable the firewall:
    gio launch /usr/share/applications/YaST2/YaST2-org.opensuse.yast.Firewall
    command line - Running a .desktop file in the terminal - Ask Ubuntu
  2. Install the printer drivers:
    sudo zypper install epson-inkjet-printer-escpr
  3. Reboot:
    systemctl reboot
  4. Verify:
    kcmshell5 kcm_printer_manager


I’m only trying to discover a local printer, connected via USB. Should that really be necessary? (I’m hesitant to, because firewall management on Linux seems much more complex than on Windows.)

Turns out that it’s already disabled:


Consequently, I enabled the firewall:

  1. image
  2. image

and now, at least YaST discovers the printer:

kcmshell5 kcm_printer_manager still doesn’t though – same error as before.

A reboot fixed it: