Can't install/use KDE Neon User Edition in VirtualBox after update to Plasma 6, it shows black screen

Can’t install freshly downloaded KDE Neon User Edition in VirtualBox 7.0 with standard VMSVGA graphic controller, it shows black screen instead installation screen. It works with glitches with non-standard controllers like VBoxVGA or VBoxSVGA. I thought it was due to the Wayland now is set by default, but I managed to install NEON with glitching VG controller and switched to X11 - it did not help - still black screen with standard VMSVGA…

NB: the install before update to Plasma 6 works fine

Have you tried to enable 3D acceleration ?

Sure, it works with 3D acceleration but very slow, like in slow-motion movie, including cursor, totally unusable.

Also in Archlinux don’t work Plasma6 with VB, use QEMU that works flawlessly :wink:

1 Like

Can you tell me what settings for QEMU do you use to make kdeneon Plasma6 work flawlessly ?

Hm. Works here without problems in VirtualBox 7.0.14 in an X11 session with VMSVGA - both with and without 3D acceleration…
I have also enabled: VT-x/AMD-V, Nested Paging, PAE/NX, KVM-Paravirtualization.

Did you try setting the video memory to the maximum of 128MB?

Did you fully update your KDE neon VM (there have been several updated packages during the last 10 days)?

Did you try a new user account in the VM?

Yea I use the same version VirtualBox 7.0.14 and tried such settings, unfortunately the result for me is the same - Wayland session somewhat works when 3D accs is on, but supper luggy (like slow motion), and once switched to X11 it works more or less fine. BUT after reboot it gets back to wayland - it does not preserve X11-setting… all recent update are installed.

Moreover when installing KDENEON with 3D-off it just shows black screen, so it is not possible even to install, so only solution is to switch different graphic controller (VBoxVGA, VBoxSVGA) then it is blinking or to switch on 3d, but then cursor is as in slow motion.

Do you know how to set X11 by default, so it does not switch to Wayland after each reboot?

macOS Big Sur 11.7.10
MacBook Pro (Retina, 15-inch, Mid 2014)
VirtualBox 7.0.14, Video Memory 128 MB
KDENEON User Edition fully updated

Do you have enabled automatic login?

To change this either to manual login or change the default session to X11 (it is a bit hidden…):
System SettingsAppearance & StyleColors & ThemesLogin Screen (SDDM)Behavior…

Probably, but I just deleted VM… can’t verify… but thanks now I know how to change default session to X11. Meanwhile I just tried again to install fresh KDENEON without 3D, it just shows black screen… can you install KDENEON without 3D being on?

I use QEMU with quickget and quickemu… so for me the defaults as generated when I run quickemu -vm distroname

I just download the iso file using quickget

I’m currently using Manjaro Stable KDE5 with Wayland

If you want to use Virtualbox, there are two practical options:

  • In the machine settings, enable 3d acceleration
  • In the machine settings, use a graphics driver other than the default one

In both cases, make sure to allocate enough general and video memory to the VM.

  1. unfortunately, the use of 3D acceleration with Wayland leads to such slowdown that it makes virtual machine almost unusable
  2. usage of graphics driver other than the default one results in interface blinking that is also unusable

I found workaround:

  1. install kdeneon with enabled 3d acceleration (painfully slow, but possible)
  2. once it is installed switch to X11 and turn off 3d acceleration
1 Like

Ultimately the problem here is VirtualBox’s defective graphics drivers. Other virtualization solutions don’t suffer from these issues. Using one of those may end up being preferable.

2 Likes