Chrome freezes desktop and tty does nothing?

For a week now, chrome would randomly freeze the desktop and apparently im not the only one. However, i read to switch to a virtual terminal, i log in, but commands like pkill seem to do nothing. It just switches to the next line and chrome is still alive as well when i switch back.

Why is that?

You may need to use different options with pkill, to run the command with more gusto if the application is being subborn.

Something like pkill -9 chrome or pkill -SIGKILL chrome.

Oh i tried them. I also tried restarting plasma, but i end up booting with REISUB, because the virtual terminal even looks different and seems inoperable. Like i dont get the typcial user@machine thing and using something like pidof, which normally provides an output about chrome for example, shows nothing when im in the virtual terminal

How much RAM do you have on your system? In my case, my laptop doesn’t have too much RAM, and it freezes the entire desktop when the RAM is full.

64 and not maxing out anywhere close at the time. Drive space isnt much but 5gig on a 50gig root partition. Thought maybe this is it as well, but i would image its enough