Clipboard is lost when application it's copied from is closed


I’ve already posted this on reddit a while ago. This could be an unwanted behaviour but most likely it’s just a misconfiguration I made.

It seems to me as if the contents of the clipboard is not copied but linked and I’m having trouble getting used to it. For Example: When I copy a string in kate and then close the application, the clipboard is empty.

I’ve already made some configuration changes on the clipper because I don’t like it. I don’t want to see it and I want it to act as old-fashioned as possible. Could I’ve done some misconfiguration that causes this or is it the intended behaviour?

I can accept that my password manager empties the clipboard after a few seconds. Aside from that, I’d prefer to have the contents of the clipboard to be persistent.

Kind regards

Try using Meta+V and you should see a history of copied items you can paste. :slightly_smiling_face:

You can open it here and edit as needed.

Thank you very much for your reply.

Sorry, that I have to ask: What is the meta-key? (I only know the one on emacs) Is it CTRL?

Meta Key
Super Key
Windows Key

It is between the left CTL and the left ALT.

1 Like

Oh, thank you. I always keep forgetting that key.

However, Meta+V doesn’t do anything on my system.

FYI: I usually had “clipboard” deactivated in all system tray settings. Because that seemed to be the easiest way to just get the old fashioned behaviour (no clipboard history and no synchronization of clipboard with selection). Of course I also tried everything with activated clipboard.

What is that “Save clipboard contents on exit” option for? Does it save the clipboard on logout? It doesn’t seem help me on this matter.

If you have clipboard deactivated, then I don’t know what to do to fix it. I just know that my clipboard will hold things beyond a reboot. To me, that is very handy.

I tried with activated clipboard too of course.

Please, could you tell me, which checkboxes you have on at “General Configuration”?

in clipboard configuration I mean

It seems the “Prevent empty clipboard” option does the trick.

Could it be that activating that solves my problem? I’ll give it a few more tries.

1 Like

As far as I know, these are default. I don’t remember ever changing them.

Thank you very much. That option dialog looks totally different for me.

Strange… I though I had the most recent version.

1 Like

I think it’s working like I want it to with that “Prevent empty clipboard” option.

Thank you very much for the assistance Wilson. I wouldn’t have found it if you hadn’t pointed me in that direction.

1 Like

Klipper is the responsible for keeping copied data from any application after it’s closed. So if you disable it, then you will lose that copied data after the source is gone.


Operating System: openSUSE Tumbleweed 20231121
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.112.0
Qt Version: 5.15.11
Kernel Version: 6.6.2-1-default (64-bit)
Graphics Platform: X11
Processors: 20 × 12th Gen Intel® Core™ i7-12700
Memory: 31.1 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2
Manufacturer: Dell Inc.
Product Name: XPS 8950

Thank you both. I need to leave now. I’ll check back later.