Compositor settings confusion

I’ve just installed the task-kde-desktop version of KDE and I was hoping to disable the compositor on startup, but the setting isn’t there.

I was expecting a setup like the image above (with a slider for animation speed etc.), but instead I’ve just got a box for latency and a tick box below it. I assume this is a difference in KDE versions and a switch to Wayland.

How do I disable the compositor on startup and achieve the same settings/results with
this reduced settings list?

You can’t in Wayland.
KWin is a Wayland compositor, that needs the GPU to function. This is very lightweight on the GPU and cheaper (i.e more performant, less energy consuming) to run graphics (aka compositing) on the GPU than on CPU.

I am betting the reason why you want to disable compositing under X11 don’t apply in KWin Wayland.

You just updated to Plasma 6.0 according to the photo of your screen, and Plasma 6.0 by default uses a Wayland session. You can pick X11 session while in sddm.

1 Like