Context menu in dolphin can not be disabled

I noticed my “open as root” context menu was missing when right clicking in Dolphin.
I reinstalled it using the ported version for plasma6 via the “download new services” button in the Dolphin/context menu settings.
I removed the old desktop file in ~/.local/share/kio/servicemenus/ and the context menu appeared when right clicking. (probably would even if I did not remove the old desktop file)

Another user on another forum asked me to confirm that if I unclick “open as root” in dolphin context menu settings it does not get removed from the menu when right clicking, and it does not.

That made me think there is something different between the config and the actual right click menu.
Because before installing the plasma 6 version of the context menu, I could still see the plugin in the dolphin context menu settings, and it was clicked.
So one might assume that the settings are accepting the old context menu desktop files, but the actual context menu does not.

Is this known? (I could not find anything on

Is this a dolphin or a general kde thing? (the context menu is ported, so there are versions for both plasma 5 & 6, so there is nothing wrong there, unless the update should have pulled the new context menu automatically?)

Do you want me to create a bug report? (I always aske here first instead of bombarding the already overworked KDE devs with a bug report that is already known/being worked on)

It does not seem to involve built in context menus, I tried disabling “mount ISO and disk images” and after a restart of Dolphin, that is gone from right click, so it is seems to only affect things in ~/.local/share/kio/servicemenus/

If it wasn’t a KDE produced addon, it won’t be for the KDE devs to look at.

If it was in ~/.local/share it highly likely isn’t a KDE addon.

Look at the first few lines of the .desktop file to find out who created it.

You seem to missunderstand.

The plugin is an addon on the kde store (or whatever they call it) and that is ported to plasma 6 just fine. As a matter of fact the dev provides versions for both 5 and 6.

The issue is not related to porting or anything like that at all and the dev of “open as root” can do nothing about this issue.

Disabling something in Dolphin settings that does not take affect is a bug, the question is, is it because of for example KDE framework or Dolphin itself?

It’s a very minor bug, but it IS a bug.

The reason I expanded about the setting seeing the plasma 5 version but not the rightclick is because if someone with a lot of knowledge reads that, they might go “oh, I know exactly why that is happening and what needs to get fixed”.

This “kde store”?

The only KDE store that exists to my knowledge.

Please stop.

If you want to help, install it via the Dolphin settings, disable it in the same settings and confirm if it is or is not still visible when you right click.

I’m just stopping you from posting a bug for something that some random person called “Loup” wrote, who I don’t believe is going to see a bug report on kde-dot-org…

Apart from helping you not post a bug report and make people waste their time redirecting it into the bitbin?

gizza sec…

Edit: Installed to the correct location it works; right clicking a directory, choosing Open as Root brings up a box asking asking for password, and then I get a dolphin window with a banner informing me that I am running as root…

It is very obvious you do not even read.
Installing it works perfectly, like I pointed out 2 times.