Could someone "translate" these xrandr commands to work with kscreen? Thanks!

I just tried out Wayland on my machine. I was dealing with some pretty obnoxious screen tearing, so I tried Wayland, which is something I’ve heard about in passing. It fixed the screen tearing, which was super nice!

Unfortunately, another problem has arisen. One of my 3 monitors is a CRT, and I think the timings for it’s highest resolution are messed up, which resulted in a lot of underscan and doesn’t fill the screen. My solution for this was just running a custom resolution. I did so with these 3 xrandr commands:

xrandr --newmode 1280x960_60.00 102.10 1280 1360 1496 1712 960 961 964 994 -HSync +Vsync
xrandr --addmode HDMI-A-1 "1280x960_60.00"
xrandr --output HDMI-A-1 --mode "1280x960_60.00"

My research has told me that I will need to use kscreen to do a similar thing on wayland. I tried simply replacing xrandr with kscreen in these commands, but that did not work (unsurprisingly)

Is there any chance that someone could “translate” these commands to work with kscreen? Sorry if I’m completely misunderstanding how this works.

Thanks a ton!

Does the Hardware → Display and Monitor section in system settings not cut it to set a custom resolution?

Unfortunately not, I don’t see an option to create a custom resolution. It allows me to change the resolution, priority, scaling and such, but no option for a custom resolution.

This was reported in 448398 – Ability to switch between unsupported resolutions like on X11 / Windows and fixed in plasma 5.25.3.