Couple dolphin questions (100% CPU usage, and headers that I can't figure out how to turn off)

Whenever I open dolphin it immediately takes 100% of a CPU core. If I open two dolphin windows, it’s two cores. Etc. Doesn’t matter which directory is open. I’ve tried disabling tooltips and unchecking all the previews, with no change. I’m pretty sure that it isn’t Baloo, top says “baloo” when Baloo is indexing and this says “dolphin.” Also this seems to last longer, Baloo does finish eventually. And this happens regardless of whether or not I have file search enabled.

I did see the bug report (427471 – Dolphin using up 100% CPU), but I don’t know if I’ve got the same problem or not. I’m having difficulty diagnosing this.

Edit: Top gives me one process per open dolphin window, with each process at 100% CPU. And the PID corresponds to the same PID that I get when I open that dolphin window via kdeinit5 dolphin, with debugsettings set to “full debug”.

htop shows two processes though, both named dolphin, both at 100% CPU, and only one of them has the PID above. When I close the dolphin window, both processes close.

I don’t know if that means anything, but I thought that was curious.

----- Below issue solved, thank you ---------------
The second thing is that I have one directory where dolphin puts in headers between the files. So if I sort by modified then instead of just giving me all the files sorted that way it will additionally put in a header telling me that these files were modified yesterday and these files were modified two days ago, etc.

I don’t know what I did to turn these headers on for this one directory, maybe I just pressed the wrong hotkey, and I don’t know how to turn them off. I’ve looked, but I just can’t find this option.

I am not sure what you mean by “headers.” Can you post a screenshot?

Like this:


Feels like a weird thing to ask for help on, it seems like there should just be a checkbox somewhere that I need to click. I just can’t find it.

Let’s think this…

You have an issue where your view of a folder is different…

… and they appear to be in, erm, groups

I’ve looked, but I just can’t find this option.

you’ve looked for view and group, yes?

Re: usage… have you got any remote locations in your sidebar (network drives, etc?)

Have you seen this?

How about Hamburger Menu
Show Additional Information

There’s “View Modes” in the configure panel. Doesn’t have anything like that in it though.

Turning off modified in the hamburger menu gets rid of the modified column, but doesn’t get rid of the headers. I can sort by something else, that will change the headers to whatever I sort by, so “A”, “B”, “C”, etc. if I sort by name.

On my Sort By, Name is selected.
In the Show Additional Information, nothing is checked.

That looks like this:


CTL+1 CTL+2 CTL+3 change between icon, compact, details. Try that.

Nope. The headers look different in each mode, but they’re still there.

there should just be a checkbox somewhere that I need to click.

psst… view… group…


I don’t run the Menu bar, but I hit CTL+M and then I can see View > Show In Groups

Thanks @Angus

For usage: I do have the default network directory in my sidebar, but hiding it doesn’t change anything.

The debugger that you linked is giving me:

“Qt: Session management error: networkIdsList argument is NULL”

Repeatedly. It’s the only thing that it’s giving me which keeps coming up unprompted, so that may be it.

Ah, there it is. Yes, CTL+M did it for the headers. Thank you.

Well, no luck with that error message. Doesn’t seem to be related from my searching on it. This is was I get from Full Debug:

kdeinit5 dolphin
kdeinit5: Shutting down running client.
kdeinit5: Got termination request (PID 15850).
klauncher: Exiting on signal 15
kdeinit5: preparing to launch ‘/usr/lib/x86_64-linux-gnu/libexec/kf5/klauncher’
kdeinit5: Launched KLauncher, pid = 16262, result = 0
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kdeinit5: opened connection to :0
kdeinit5: preparing to launch ‘/usr/bin/dolphin’
kdeinit5: Launched ‘dolphin’, pid = 16265 result = 0

I edited the top comment to note that the PID which it gives me here corresponds to the process in top and the only one that shows when I do “ps -A | grep dolphin”, but when I run htop there’s a second process labeled dolphin which also takes 100% cpu. I am confused by this.

The system is basically idle other than dolphin.

I’m not sure what’s up with that. I look at mine and it is 0% CPU and .4% RAM. I also see multiple instances of it.

If you run dolphin from the command line, do you get errors at all?

I just checked ~/.config/dolphinrc and I don’t see anything there that might help you.

The above is what I get if I run it with “kdeinit5 dolphin”. If I run it with just “dolphin” I get:

Qt: Session management error: networkIdsList argument is NULL

Could it be that something is missing? I had another seemingly unrelated problem with my video drivers which I solved by installing the headers for my kernel. Which were… not there. I ran “apt autoremove” at one point in order to free up some space in my boot partition and it seems to have broken some things.

Does this happen in X-11 or Wayland? Have you tried switching to the other, or does it happen in both? Also, what distro are you running? What hardware and such?

Okay, I have (just now) tried it in Wayland and it does the same thing with consuming CPU. Though I don’t get the same error above. Instead, I got no error when I started dolphin, but when I closed it I got this:

KCrash: crashing… crashRecursionCounter = 2
KCrash: Application Name = dolphin path = /usr/bin pid = 4418
KCrash: Arguments: /usr/bin/dolphin
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
:~$ org.kde.drkonqi: The specified process does not exist.
Exception ignored in: <_io.TextIOWrapper name=‘’ mode=‘w’ encoding=‘utf-8’>
BrokenPipeError: [Errno 32] Broken pipe

In X-11 I get the error I mentioned above when I start it, but no error when I close.

Although, come to think of it, I didn’t start the Full Debug from kdebugsettings in wayland. Maybe I have to do that separately.

Okay, so the full story is that I got this laptop about a month ago and installed Kubuntu. Everything was fine until about a week ago (dolphin was well behaved, and my nvidia drivers were working, and… well I did have some other problems. Lets ignore those.). About a week ago I had an update which failed, and then the next time I tried to boot I got a kernel panic.

I was still able to boot by switching to a different kernel in grub, for some reason I had a whole bunch of kernels installed, and I identified the problem as lack of space in my boot partition. So I apt autoremoved and that got rid of most of those kernels and let me update, and then I could boot again normally.

But, my discrete GPU was no longer working. I have an integrated AMD GPU, and a discrete Nvidia GPU. That problem turned out to be missing kernel headers. Solving it just meant installing those, and then my GPU worked again.

It’s possible that apt autoremoved those headers, or it could be that the kernel I had been using originally was removed and the one that I’m using now never had those headers installed in the first place. (I don’t know which kernel I was using originally. Could have been this one, or another.)

Come to think of it, autoremove got rid of all but two kernels. But that means I still have a different one, I could try booting with the other kernel and see if dolphin behaves the same way.

I’ll go do that and then I’ll edit this comment.

Edit: Okay, well no difference at all. Same error message, same CPU consumption for dolphin. My nvidia drivers aren’t working with this kernel, presumably because the headers aren’t installed, but everything is otherwise the same.

That sounds like a lot of leads to try to run down and fix if the issue, if it is ever found. I am not familiar with Kubuntu, so I will let someone who knows more about it try to help. It might be handy to try installing something like thunar to see if it does the same thing.

Just my opinion, so it holds no weight. If I thought it might take a lot of work to track down and fix such and issue, I would back up my ~/home folder excluding the .cache folder and just reinstall from scratch. Sometimes it just ends up being a lot easier and faster. :slightly_smiling_face:

I’m not going to do that. It’s been such a headache getting everything working, there’s always some little thing, and I’m almost there… Thunar is not causing me any problems. I guess that’s a workaround, for the time being.

Thanks for the help, I’ll keep my fingers crossed for a long term solution.