Ctrl-click on a .py file listing in Konsole opens kate instead of default editor

In Konsole, let’s say I do a ls -1 and then ctrl-click on a entry for file.py. As far as I understand, this should open the file in my default text editor. Right now it’s opening in kate, but I want it to open with code --wait.

Here are some screnshots of my settings:

Notice how the file associations for both x-python and x-python3 have Visual Studio Code as the top entry, and my EDITOR env is also set to code --wait.

What could be the issue and how can I fix it?

Does this happen only in Konsole? Does it start vscode if you open from Dolphin?

€: Possibly this bug? 471004 – ctrl-clicking a .txt file does not open the editor I expect.

Yes, only in konsole. Dolphin opens it just fine in code.

Thanks for linking to that bug report. Yeah, I submitted that very bug report a month and a half ago and it’s pure crickets. So I thought I’d try here for some more support?

Are you able to ctrl-click a file in konsole and get it to open in vscode? Sometimes knowing if “it’s just me” or if it’s everyone helps narrow down the problem space significantly.

I think I figured it out.

Konsole doesn’t use the File Association from Systemsettings. Instead it uses the Editor you define in the Konsole Settings: Settings -> Edit current Profile... -> Mouse -> Miscellaneous -> Text Editor Command

Check if that works for you.

That’s IT!!! :smiley: I deleted that setting and it is now using the system wide default.

Thank you so much for your help finding that, @Duha! I searched all over the settings but never thought of looking in the profile, as I’m not sure why this would need to be hot swappable.

Anyway, you solved a major issue in my workflow, and I want to thank you from the bottom of my heart! I hope you have a fantastic day. :smiley: