Customizing scrollbar size

Hello guys, I’m not only new to KDE forums but I’m also new to linux in a sense that I dumped windows and installed debian on my hard drive for good.

The issue I’m having is scrollbar size is so tick I need to aim with the mouse and hope to grab it, it feels difficult like shooting characters in FPS games.

There appears to be a ton of complaints online about this and there are various bug reports which are marked as “solved” but are not solved, for ex:

There are also various solutions on Q\A sites such as editing the gtk.css file either in /etc/themes directory or in ~/.config/gtk-3.0/gtk.css
example which I followed:

Sadly editing the css file in theme directory didn’t work for me (I did make sure to undo the changes to original values ofc.)

So I need help with this, how do I adjust scrollbar size so that it works?
I’m using KDE plasma 5.27.5 on debian 12
The theme I’m using is “Breeze Dark”

gtk-3.0/gtk.css only applies to Gtk3 applications.

The Klassy application style allows you to modify scrollbar width for KDE/Qt applications in the settings.

1 Like

Thank you, I’ve installed Klassy and enabled it, however I’m not able to find the dialog shown in your screenshot, where to run it?

Another question, to make it consistent with gtk programs if I understand I’ll need to update gtk.css anyway right? since klassy handles only Qt programs as you said…

I figured out how to bring up the dialog and customize it, it works thanks!

1 Like