Date Format not sticking to Regional Choices

I picked UK regional & English UK plus UK Keyboard.
If i check this in Settings in KDE is shows UK.
But it keeps displaying US date format all over in settings page in Dolphin.
You can reset it then reboot it shows correct but after next reboot back to US format.??
Is this a bug or am i missing some other settings i need to change.
I have just re selected UK rebooted and here are the images

See here

Can you paste the contents of ~/.config/plasma-localerc?

Also the output of running env | grep -i LANG in a terminal window.


Terminal Output

[] ~ env | grep -i LANG
[] ~

Hmm, those settings look correct to me. Not sure what could be going on.

Even the clock in the tool bar will not display like 19:24 hrs even though that is set.

If i try to change it i get a popup
Locale and language support files have been generated, but language-specific fonts could not be automatically installed. If your language requires specialized fonts to be displayed properly, you will need to discover what they are and install them yourself.