Date is using UTC time rather than local time

can confirm today fri 9/8 that when i open Kalendar and choose Today it says it’s Saturday 9/9… this is at 6:15PM local time but 1:15AM UTC

so Kalandar does not seem to be respecting my local time setting even tho i used this command to tell linux to use local time

timedatectl set-local-rtc 1 --adjust-system-clock