Different result when exporting to 1080p vs 720p

I’m on Windows 11 using Kdenlive 23.08 and I have a 1080p kdenlive project where I added a 4k image, then added a transform effect. Resized it to 10% of its original size and made a small animation moving the image to a corner. This is just for test purposes in my project I do something similar.

Then I proceed to render it to 1080p. I use the predefined preset called MP4-H264/AAC for this. Then I duplicate that preset but change the render output to 720p. The exported video looks very different as if it was zoomed in.

This is the 720p export (I cannot post the 1080 as I can only post one media because I’m new user), in the original video the image moves to the corner but doesn’t go out the frame, however here as you can see it’s like zoomed and it goes out

By the way this only happens to media with a transform effect applied.
Any ideas?

I saw another post (cannot post links search for “rescale while rendering transform effect cropped video of top left corner”) and the fix mentioned there didn’t work for me.

EDIT: This also happens on version 24.02 I just tested it, maybe there’s a setting I’m missing?

This is the 1080p export (I had to add it as reply)

Unless I’m missing something, if you’ve told the transform to position it in the bottom corner of a 1080p frame then only rendered a 720p subset of that - this is what I would expect to see?

Try using the “rescale” option in the render dialog if you want a scaled down version of your 1080p project. I regularly use that to render out 4k video at 1080p, and only rarely does it do something unexpected to the output.

1 Like

I was editing the presets, I didn’t see the “rescale” option, my bad :frowning:

It was a little bit confusing though, because in the example above, if i set a background image, without a transform effect, the background image gets scaled properly according to the preset.

Everything works now so I’m happy that I understood what was happening :slight_smile: Thanks again

1 Like