Digikam adjust time

I’m not expert enough to be sure this is a bug.

I tried “adjust time” subtracting one hour from all items (because I had changed time zones when taking the pictures and my devices had failed to adjust).

All .arw (raw for my camera) failed to adjust and all other file types (that I had) adjusted.

I had all the options in the default (checked) mode.

Should I try turning some of them off to see if some of the adjustment of .arw works?

Any other suggestion?

Or, if it is a bug, what evidence should I gather for reporting the bug?


Which platform are you using?

  • Linux or one of the two alternatives?

For the case of your Sony ARW files – the “ExifTool” CLI tool can handle the timestamp placed by the camera in each file’s header – <https://exiftool.org/>

I’m not sure if, the digiKam “Time Adjust” tool can handle anything other than JPEG files.

Thankyou for the reply.

I retried, gradually turning off options,
EXIF: original
EXIF: digitized
IPTC: created

With those off, it still didn’t work. Then I also turned off
EXIF: created
and it did work.

Other than Digikam’s own database, I’m not yet sure which of the many places where the date was stored actually changed when that “worked”. (EXIF: Thumbnail and File last modified were both still checked. XMP: Video was sill checked but wouldn’t apply).

I haven’t yet tested turn back on subsets of those first four.

I have Digikam on both Windows 10 and Fedora and can easily access the same (Windows) folder hierarchy of photos from either. But moving the DB is inconvenient.

It is more convenient for me to use Digikam on Windows. But I have used it on Fedora (because I’m kind of able to change and rebuild it on Fedora, while NOT yet able to rebuild on Windows). So anyway all that “adjust time” usage was with both the execution and the photos on Windows.

Do you think it would matter if the execution were on Fedora? If so, would that need the folders to be native (vs. cifs mount)?

It can. But with limits and or bugs I only partially understand.

The answer is here – <https://docs.digikam.org/en/supported_materials/image_formats.html#raw>

digiKam supports RAW image loading only, relying on the Libraw library which is included in digiKam core and supports over 1000 RAW file formats.

In other words, the Sony ARW files are only supported as “loading only” – and, nothing else …

For your current Use Case – «Setting image file timestamps» – the platform doesn’t really play a major role – apart from the selection of external tools which support various EXIF manipulations …

A little bit of additional information – Phoronix released the following Benchmark results yesterday – 18th of April 2024 – <Ubuntu 24.04 Boosts Performance, Outperforming Windows 11 On The AMD Ryzen Framework 16 Laptop>

BTW, my daily use platform is as follows –

Operating System: openSUSE Leap 15.5
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 5.14.21-150500.55.52-default (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 3400G with Radeon Vega Graphics
Memory: 29.3 GiB of RAM
Graphics Processor: AMD Radeon Vega 11 Graphics
Manufacturer: ASUS