Disable tooltips in plasma


im using Orchis kde global theme with orchis kvantum theme and the tooltips keeps showing tough i disabled it in settings

Hi @HyPhen404!

Can confirm the same behaviour with Breeze theme and Light Breeze for plasma, even in the same preferences window the buttons in the bottom keep showing tooltips.

One thing I haven’t tried yet is logout/login after disabling tooltips.
Have you tried that @HyPhen404?

1 Like

Can also confirm on Plasma 5.27.4 using Breeze Dark. Re-logging or rebooting did not work either.

1 Like

Perhaps Konsole isn’t respecting that setting? Is it broken in all KDE or Qt apps, or just Konsole?

1 Like

It’s starting to occur to me that this might be one of those dreaded “Broken Promise” features

1 Like

i think all the other apps as well dolphin hamburger menu kate and some other ive noticed this tooltips behaviour as i hover

i tried that as well it doesnt seem to be working for mee.

From the help page for those settings:

Display informational tooltips on mouse hover
If this option is checked, tooltips are displayed hovering items in the Plasma panel or on the desktop.

1 Like

Urgh so it’s a Plasma-only setting. We need to communicate that in the KCM somehow, because nobody reads the help pages.

2 Likes

Yes!

Even after reading the help page I was unsure.
What does “desktop” refer to? It works as intended for the Plasma panel (even without rebooting). Are there tooltips on the “desktop”?

€: Seems like it works for Widgets like the Analog Clock, but does not work for Kickoff or Krunner which is probably also intended. Icons don’t have any tooltips for me anyway.

1 Like

I’ve started a developer discussion about what we should do here: Plasma 6 discussion: what do we do about the "disable tooltips" option? (#83) · Issues · Plasma / Plasma Desktop · GitLab

4 Likes

this behaviour doesnt happen to seem in the breeze theme tough.

hey i was able to disable the tooltips from kvantum theme manager where i configured the theme settings and set the tooltips delay to -1 ms that solved my issue.

1 Like