Disable window auto-resizing when dragging

I can’t find out much about this behaviour, but it might be called snapping? My windows have started going to either full height or half height when I’m trying to move them around. I can’t find out what this setting is or how to disable it.