Discover - failing to start (GLib-ERROR Creating pipes for GWakeup: Too many open files)

When I try to use Discover on my MX Linux

Kernel: 6.4.0-4mx-ahs-amd64 [6.4.13-1~mx21ahs] x86_64 bits: 64 compiler: gcc v: 10.2.1

Desktop: KDE Plasma 5.20.5 wm: kwin_x11 vt: 7 dm: SDDM

Distro: MX-21.3_KDE_x64 Wildflower January 15 2023

base: Debian GNU/Linux 11 (bullseye)

I get the following message.
Can anyone offer any advice, please?

bambuko@bambuko-mx:~
$ plasma-discover
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/GlobalDrawer.qml:265: TypeError: Type error
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:162:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:99:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/OverlayDrawer.qml:284:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:162:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:99:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/RefreshableScrollView.qml:137:13: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:162:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:99:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:139:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:139:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/AbstractApplicationHeader.qml:139:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
adding empty sources model QStandardItemModel(0x55f994453e50)
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:71:5: QML Binding: Binding loop detected for property "value"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"

(process:13201): GLib-ERROR **: 09:32:04.644: Creating pipes for GWakeup: Too many open files
Trace/breakpoint trap

I’m having the exact same error. The only difference seems to be that I’m running straight Debian 11.

1 Like

Thanks !!
I know it is not a solution, but delighted to know that:
a) I am not the only one
b) it is not just MX but also straight Debian
Let’s hope someone knows what is going on…

I have another machine running Debian 11 plasma and that’s showing the same too. I span up a VM running Debian 11 and low and behold, the same error. Curiously I did the same for Debian 12 and that was fine. I wonder if it has anything to do with the fact that Debian 11 is running a very old plasma?

@DaBaby
definitely sounds like it is “old” Plasma problem?
I have resisted move from 11 to 12, since
(in my humble opinion :yum:)
rather than solve old issues it simply introduces new ones…

I would love to know what is wrong? but it is well beyond my capabilities …

No such issues in my Debian 11 VM

Maybe you made your system a bit frankensteiny by installing a newer library version from a backport or some external source or something, you should look for that error (process:13201): GLib-ERROR **: 09:32:04.644: Creating pipes for GWakeup: Too many open files

I’ve fixed it but I’m not sure it’s the correct solution. @rockandstone inspired me to create a brand new VM on Debian 11 and start playing. I have flatpaks integrated into discover with the backend plugin and as soon as I installed that the error occured. I’ve countered this by increasing the the maximum number of files with the “$ ulimit -Sn” command. I increased mine to 4096 by “$ ulimit -Sn 4096” and then launched discover from the terminal with “$ plasma-discover %F”. It seems stable right now. Hope this helps.

1 Like

sounds legit. You probably need to raise that number the more flatpaks you use.

how many entries does a $ du /var/lib/flatpak | wc -l show?

(another flatpak limitation no one has thought about :face_with_hand_over_mouth:)

thanks @rockandstone
I have tried your suggestion and most of mine were exactly the same as yours with exception of five lines:

ii  libappstream-glib8:amd64          0.7.18-1+deb11u1    amd64        GNOME library to access AppStream services
ii  libglib-object-introspection-perl 0.049-1+b1          amd64        Perl bindings for gobject-introspection libraries
ii  libglib-perl:amd64                3:1.329.3-1+b1      amd64        interface to the GLib and GObject libraries
ii  libglibmm-2.4-1v5:amd64           2.64.2-2            amd64        C++ wrapper for the GLib toolkit (shared libraries)
ii  libkf5kmahjongglib5               4:20.12.1-1         amd64        shared library for kmahjongg and kshisen

none of this looks suspect?
although I have no clue why I have “kmahjongg and kshisen” ???

It shows 15991. I don’t have too much installed from there but I tend to because I like the control flatseal gives me. I didn’t install anything new before I started receiving the error. If I had it would have been the first place i started looking.

are you also using (many) flatpaks like @DaBaby ? Have you tried his solution?

thanks @DaBaby
I have few flatpaks as well:

$ flatpak list --app
Name                          Application ID                  Version       Branch       Installation
VidCutter                     com.ozmartians.VidCutter        6.0.5.3       stable       system
Bottles                       com.usebottles.bottles          51.10         stable       system
Youtube Downloader Plus       io.github.aandrew_me.ytdn       3.17.0        stable       system
Kdenlive                      org.kde.kdenlive                23.08.4       stable       system
Zim                           org.zim_wiki.Zim                0.75.2        stable       system

so, I followed your advice about increasing the number of files, and!!!
hey presto it works OK.

I have tried something like this before posting here, but must have messed it up - your clear instructions have helped !
Thank you
P.S.
why 4096 ?
what’s the significance of this number? pleaSE

mine shows 9274
so should be OK??? (and not as large as @DaBaby )

It was default at 1024. I doubled that and still got the error so I just doubled again.

just replied below (or above depending on your settings),
yes and yes and yes - it works !!

1 Like

yeah I don’t know how relevant the absolute number is in this case, I was just curious to see if it is. You should be probably fine and if not you could increase that number further.

Now to make it permanent until I make the leap to 12. Thanks guys.

Indeed, thank you both for the help
I am a happy chappy tonight :slightly_smiling_face: