Discover sending user in circles with version warnings

Install Blender on Linux | Flathub and Fedora Flatpaks both cause discover to display:

This development version of Blender is outdated. Using the stable version is highly recommended.

whereas “Fedora Flatpaks (Testing)” causes it to state

A more stable version of Blender is available.

Consequently, the sole option without this warning is the RPM:

This is a bit of a catch-22, incentivising users to use their native distributions’ packages. Is this what we want?

The message is not supposed to appear for the Flathub representation, because 4.1.0 is in fact the latest version of Blender. On my system I don’t see it, but I do see it for the Flathub beta representation, where it correctly warns me that version 2.80 available there is woefully outdated and I should use the stable version instead. I suspect you’re seeing an issue on your system due to a subtle bug triggered by your enthusiastic usage of many many many software repos.

Which is not to say it’s not a bug or that we should ignore it. But right now I’m mentally filing it in my bucket of “can’t reproduce with a more typical setup; user has probably shot themselves in the foot; ignoring in favor of more pressing things” :slight_smile:

1 Like


Not on this installation. It’s new, and I don’t intend to add many RPM repositories like I did on OSTW:

RokeJulianLockhart@sayw4i:~$ dnf repolist
repo id                                                   repo name
code                                                      Visual Studio Code    Copr repo for CoolerControl owned by codifryed
fedora                                                    Fedora 40 - x86_64
fedora-cisco-openh264                                     Fedora 40 openh264 (From Cisco) - x86_64
fedora-cisco-openh264-debuginfo                           Fedora 40 openh264 (From Cisco) - x86_64 - Debug
fedora-debuginfo                                          Fedora 40 - x86_64 - Debug
google-chrome                                             google-chrome
google-chrome-unstable                                    google-chrome-unstable
rpmfusion-free                                            RPM Fusion for Fedora 40 - Free
rpmfusion-free-updates-testing                            RPM Fusion for Fedora 40 - Free - Test Updates
rpmfusion-nonfree                                         RPM Fusion for Fedora 40 - Nonfree
rpmfusion-nonfree-steam                                   RPM Fusion for Fedora 40 - Nonfree - Steam
rpmfusion-nonfree-steam-debuginfo                         RPM Fusion for Fedora 40 - Nonfree - Steam Debug
rpmfusion-nonfree-updates-testing                         RPM Fusion for Fedora 40 - Nonfree - Test Updates
updates                                                   Fedora 40 - x86_64 - Updates
updates-debuginfo                                         Fedora 40 - x86_64 - Updates - Debug
updates-testing                                           Fedora 40 - x86_64 - Test Updates
updates-testing-debuginfo                                 Fedora 40 - x86_64 - Test Updates Debug

Solely the VSCode (code), single COPR, and RPMFusion repositories have been added. However, none of these should affect Flatpak.

Additionally, I have nothing except the default Flatpak repositories added:

RokeJulianLockhart@sayw4i:~$ flatpak remotes
Name           Options
fedora         system,oci
fedora-testing system,oci
flathub        system

Lastly, this bug only occurs 90% of the time I visit the page, so it’s possible you’re just not seeing it yet - of the 6 times I’ve checked (in order to capture screenshots) on the 4th time, there was no warning on Flathub’s listing.

I just thought that that was a bug, so I didn’t mention it. XD

My first thought is that this might be from having both Flathub and Fedora’s flatpak repo enabled together, “confusing” whatever math is being used to determine priorities/status/whatever.

Adding Fedora’s flatpak repo to my system does make Blender act like this. Disabling/removing it fixes the issue. My PC is not running Fedora but that is immaterial, for flatpak.

Is Flathub enabled by defualt in Fedora, now? When I was using it on my last laptop (38), I did have to enable it, since the Fedora flatpaks were not always the most current.

1 Like

@claydoh, I’m using the Fedora 40 Beta KDE Spin, and it wasn’t enabled by default. I had to enable it using KDE Discover’s pleasant little button instead.