Dolphin: All file associations lost and "open with" provides no options

I am using dolphin in bspwm and whenever i try opening anything in dolphin it dont show any package to open with it
other file managers easily open the files and shows applications in open with section

also the problem is only with bspwm session in kde everything works just fine

i check mimeapps.list but nothing was wrong there
nothing was wrong with my bspwm config files which would affect something
also i tried reinstalling dolphin several times
also i tried removing dolphin config files
also i tried installing my distro again and then checking
i also tried reinstalling dolphin via flatpak

all of these tries didnt solve the problem

i am using arch linux with bspwm and kde plasma

openwith data depends on the kbuildsycoca process to populate a cache for mimeapps.list that Dolphin uses.
Dolphin is supposed to fill up this cache if it is not present IIRC.
The file is supposed to be located in a file like ~/.cache/ksycoca5_*.
You can try running kbuildsycoca5 for dolphin up to 23.08 and kbuildsycoca6 for dolphin 24.02 and restart dolphin.

1 Like