Dolphin file manager no able to establish connectiong with webdavs server that request for user agent


I couldn’t find any soln on the web anywhere for months already. Hence have to come to seek for help… hopefully someone able to help me.

Dolphin and winscp (windows os app) was able to connect to a company webdavs (https) server wonderfully, connection and copy files are tremendously fast, very satisfying.
but the company updated the server so that it takes user agent from client before allowing connection.
So now, dolphin is no longer able to access to the webdavs, however winscp still able to access the webdavs just fine.

Is there anyway to config user agent on dolphin side ? it is so sad that dolphin can’t connect to webdavs that require client to provide user agent .

I am running manjaro kde plasma.
Kernel: 5.15.146-1-MANJARO arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.27.10 Distro: Manjaro Linux
Dolphin file manager Version : 23.08.4-1

Your favorable reply will be very much appreciated.


That’s a feature whose UI was removed Remove the Browser Identification KCM (!438) · Merge requests · Frameworks / KIO · GitLab unfortunately.
I’d encourage you to open a bug asking for the feature linking to this MR.

You should be able to configure manually still, I don’t know how exactly though.
You can see the code defining it:

Would welcome users using this feature to post example of their configuration file.

1 Like

That’s a stupid “security” feature to have IMO. This is completely spoofable cannot achieve any security improvement.

Maybe you can use davfs2 and systemd automount or smthn instead to create the mount?

I am currently using davfs2… working…

However ls cmd is sluggish. Make it not usable.
For example, after mounted to my local folder, when i run a $ls cmd in the mounted folder, it took like 20-30 seconds for the list to come out… hence i resolve to $dir cmd which is faster… and uses rsync to download which is quite fast.
If i know what filename is it to download; then this method is quite good, apart from the sluggish with $ls cmd…
BTW, " $ls -l" won’t really work… it takes long long time …

i think davfs does not carry files’ time stamp property. I have tried using
$ find ~/mountedFolder -type f -ctime -2 … it can take up as long as multiple minutes until i cancelled it.

Why dolphin that runs kio is must better choise for me. In term of browse and click and download, Dolphin via kio respond is very fast… as fast as browsing local file. That makes download speedy… very good … until the server changed to require user agent .

yeah and unfortunately this stupid security feature is highly requested, when I was working at Nextcloud we had to implement it because some customers wanted it badly…