Dolphin Menu Bar not showing

Hi there… so I’m going through my files and organizing things, and I went to change the view in a folder and I realized the menu bar (where File, Edit, View, etc live) is just… gone.

I did find the KDE docs page here that explains that CTRL+M will show the menu bar.

Well… it isn’t working. I even restarted my computer. Tried both Control keys (in case it was sensitive as to whether it’s the left or right control key) and still nothing.

Is this something anyone else has encountered? Anyone have a fix? Currently I have to go to the hamburger menu, then go all the way down to the “More” option to see the regular menu options. I’ve checked my settings for Dolphin and I can’t see where to turn the menu back on if CTRL+M doesn’t work.

Picture of the only place I can find the traditional Menu settings

I’m still fairly new to Linux being my daily driver, but I’m doing my best to learn, any help would be appreciated!

System info:

Operating System: Kubuntu 23.04
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.0-27-generic (64-bit)
Graphics Platform: X11
Processors: 16 × Intel® Core™ i9-9880H CPU @ 2.30GHz
Memory: 31.2 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2080/PCIe/SSE2
Manufacturer: HP
Product Name: OMEN by HP Laptop 17-cb0xxx
Dolphin Version: 4:22.12.3-0ubuntu1

See comment #2 and #3

First of all, if you just want to change the configuration and always have the old-school application menus - you can open the hamburger menu, click “More” and then check “Show Menubar with all actions”.

Other than that - regarding the non-working keyboard shortcut - are you perhaps using a Dvorak layout (or another non-QWERTY layout)?

Okay, so I tried #2 - followed the link in that comment, did what the comments on that bug said, yes I had those entries in the sessions file. Rebooted. Still no menu bar.

Did what #3 says, and, well…

It’s not a menu BAR - like the screenshot in Discovery shows a menu bar, but it’s options, however it’s opening on a different screen entirely - which is a problem

I just want the regular, traditional, old school menu bar back :cry:

So… I 100% do not have that menu option under “More”

Also, I’m using the standard Qwerty keyboard layout. Zero modifications

Edit for wrong image - fixed now

Wow. I was wondering what that button does - but couldn’t get it to do anything for me. I guess it was showing things off screen.

As you should be able to see in the rest of the discussion in that thread - #3 is not the solution for your problem.

Yeah, I definitely realized #3 isn’t the fix I’m looking for

Oh, yea - I missed that. Sorry.

For me it looks like this:

What version of Dolphin are you using?

Dolphin version 22.12.3

Edit: just checked to make sure I wasn’t missing updates, and I’m up to date as far as Discover is concerned.

It could be that the “Show Menubar” option is new to the 23 series.

When you click menu → Configure → Configure Keyboard Shortcuts, and search for “Menu”, what do you get?

I have this:


If you don’t see [CTRL]+[M] there, maybe see if it was removed by mistake and set it up again?

I’ve got the keyboard shortcut there! But for some reason it’s not working.

OK… I don’t know why the shortcut doesn’t work for you, and I have a feeling its a big issue and will be a problem in the future - but instead of debugging that, here’s a silly workaround for how to get your menubar back:

  1. Open menu → configure → configure toolbars:

  2. Search for “menu”:

  3. Select “Show Menubar” and click the right pointing arrow button in the middle, “Show Menubar” should appear at the end of the right list:

  4. Click “OK”. You should now have another button to the right of the “Open Menu” button:

  5. Click it and you’ll get the menu bar back.

You can also now go back to the “Configure Toolbars” dialog and remove it, if you don’t want it.

When you have the menubar showing, the hamburger menu will not show, so you get either this or that.

… okay, so… I’m guessing there’s something really wrong with my system. I added it just like you showed…

And well, it’s just plain not showing up. I clicked apply, I clicked OK, I closed it, I reopened it, and the button just… will not show up. I even moved it to be between the Search and Open Menu icon to see if it would show up there. And it doesn’t. :upside_down_face:

So… yeah… thinking something is SERIOUSLY janked in my system at this point.

And all because of a menu bar :woman_facepalming:

Ooookkeeeyyy. Its time to take the gloves off.

Try this:

  1. Close all the Dolphin windows.
  2. Open Kate (or KWrite or whatever editor you like) and open the /home/YOURUSER/.config/dolphinrc file.
  3. Find the line that says [MainWindow]
  4. Somewhere underneath it there should be the line MenuBar=Disabled (it could be like 20 lines or more under it).
  5. Change it to MenuBar=Enabled
  6. Save and close the file

See if Dolphin has a menu for you now.

BTW - I’ve just tried to run Dolphin 22.12.3, and it looks fine: has the “show menubar” menu option, shows the “show menubar” toolbar button (with full text, for some reason) and looks fine:

Can you check something for me in a terminal? (open the Konsole application if you are unsure what terminal to use)

Please run: which dolphin (type that an press ENTER)
And then: dpkg -V dolphin (and again with the ENTER)

And paste the results here. Thanks.

I found the entry, I changed it to enabled, even rebooted the computer. Still no menu bar. Just my luck :upside_down_face:

I’ll go do what you said in your other reply now.



I get… nothing?

Yea, that’s actually good - it means “no verification errors”.

OK. this all checks out. I need to check some things…

1 Like

Good to know something did what it’s supposed to! :sweat_smile:

But seriously, thank you for all the help!

Editing this post because I reached max number of posts for a new user on day 1

Well, I tried it. Even rebooted just to be sure.

No dice. And i made sure to reboot without opening Dolphin just to be safe.

Still no menu bar. Still no option under “More”.

I also thought to check some other programs, and any program that should have a menu bar like that. From LibreOffice Write to OBS doesn’t have one. They seem to be gone from my system entirely. Which is worrying tbh


I’ve installed Kubuntu 23.04 and tried to mess with Dolphin. I can get the menu bar to work with the UI, but I can’t get it to work with editing the configuration file - Dolphin somehow detects that I messed with the configuration file and rewrites it. This is probably the reason it didn’t work for you.

Can you try to delete the .config/dolphinrc file and see if that helps Dolphin behave better?

1 Like