Dolphin not showing tags

Hello all!

I’ve recently begun the habit of tagging pics on my ZFS storage array. I do this within Dolphin itself. The tags save, but when I use the details view, & select the tags column, none show.

any idea what I’m doing wrong?

For tags to work you need to have file indexing aka baloo turned on.

Oh ok, silly question, how do I do that? :confused:

KDE System Settings → “Workspace” → “Search” → “Enable File Search” …

Optionally –

  • Also index file content
  • Index hidden files and folders

Personally, I do not use the file search options and, recommend them only for one or two very specific Use Cases.

You can also setup the “Folder specific configuration

Personally, I only index my Home directory and other personal directories on other drives. I explicitly disable indexing on the following directories –

  • /mnt
  • /run
  • /srv
  • /tmp
  • /var

turning on file indexing has solved my issue! :slightly_smiling_face:
thank you so much for your help! :slight_smile:

well that’s a fail after all - indexing would complete, but then start from the beginning after each boot.

You don’t say what distro you are using, it might make a difference.

I am assuming the ZFS array is local and not on a NAS. I remember a comment from a while back that Baloo does not work with ZFS (it’s mentioned in the middle of Bug 402154 – Baloo reindexes everything after every reboot when using BTRFS filesystem)

What happens when you search for a file you know you’ve indexed?

baloosearch -i A-file-I-know-I-have.txt

do you get several hits for the same file?

You can also check what the “stat” command says about your test file:

stat A-file-I-know-I-have.txt

look at the line with the Device and Inode details, it will look something like:

Device: 0,41    Inode: 8463253     Links: 1

Check again after you reboot and watch to see if these details change.

I don’t know if this will be useful for anyone but here goes.

Under ext4 and xfs I have actually managed to get my tags working in my home folder without the need to index the whole of the home folder. The following trick is good for efficiency in case you want tags enabled but you don’t want to use the built-in baloo search functionality.


  1. Created a subfolder: /home/yourusername/Useless_empty_folder
  2. Go to System Settings → File Search
  3. Click “Enable file search”
  4. Click on the “Add folder configuration” button and add the new /home/yourusername/Useless_empty_folder
  5. The “Useless_empty_folder” now appears inside the “Folder Specific configuration” list
  6. Set the “Useless_empty_folder” to “Indexed”
  7. Set your home folder “Not indexed”
  8. Close all you open Dolphin windows.
  9. Re-open Dolphin. Now the tags in your home directory should appear in their column at the Details view despite the fact that you home folder is not actually indexed!

Kubuntu LTS 22.04

ZFS is indeed local

when it finished the indexing the 1st time, it allowed me to fix the OP issues + search via tags.

… without the need to index the whole of the home folder …

It’s also worth noting that you don’t need to enable content indexing in Baloo in order to index the xattr tags.

Most of the overhead of running Baloo comes from when it tries to open, convert to text and index all the words in each of your files. That can be heavy…

1 Like

Kubuntu LTS 22.04

That will have the version prior to:

If you notice strange behaviour then do the “baloosearch” and “stat” troubleshooting steps as above (and perhaps open a bug in https://bugs/