DRM Content won't play

Hi all,

For some reason I can’t play DRM content videos on Amazon or Youtube - I’ve tried multiple browsers and yes, I have also made sure I have the option selected. It was working for a while on Chrome, but after an update that has also stopped.

On Firefox it says the widevine thing has crashed - it’s installed and seems to be updated.

I’ve searched for an answer, but nothing for KDE Neon, and most of the advice is 'reboot the browser and make sure you have ‘enable DRM content’, so I am at a bit of a loss.



Have an example Video for me that i can test it here?

Not really, it’s all purchased videos on Amazon and Youtube (‘free’ content works fine).

Ok, yeah sorry. Then i can’t help you at the moment. I cancelled my amazon account 2 months ago. Because the bad quality of 4k movies.
I remember that it always worked in the web browser under Neon. (Chrome). But there not even HD quality worked. This only worked with Windows.

€: Maybe I am wrong and this is a Neon issue:


Most likely not a KDE issue. You probably are probably better of asking on a different forum/platform with more users for non KDE related issues. Weird that multiple Browsers don’t work.

All I can say is that it works fine for me with Firefox.

Widevine is what Firefox uses for DRM content. You need to figure out why this crashes, otherwise you cant watch DRM content (on Firefox).

You don’t need to search for Neon specifically since this is most likely not Neon specific. Neon uses Ubuntu as its base so you can also search for Widevine crash Ubuntu crash etc…

If you want to debug this issue here you need to post the actual error message you get. Start Firefox from Konsole and see if you get good error messages. Try if it crashes on both X11 and Wayland etc…

Sadly this is a well known issue with DRM. 1700815 - Implement HWDRM video playback with libva protected content API
Not sure if we can expect a fix soon :confused:

Thanks for that link.

Indeed this is a well known issue. And yes, it’s a kde neon issue with apparmor. Someone came out with a fix long time ago.
This is what I wrote the neon devs:
Are you aware, since you now switched back to deb-firefox instead of snap, that drm doesn’t work due to apparmor problems? Someone even came up with a working patch! github:/Kylar514/KDE-Neon-Firefox-widevine-fix
(what it does: it adds to /etc/apparmor.d/usr.bin.firefox following new line: NEW_LINE=“owner @{HOME}/.mozilla/**/gmp-widevinecdm//libso m,”)
Probably it’s a good idea to integrate it because there are a lot of vod-watching people around, don’t you think?

They couldn’t look into it yet though

Agree, this is 100% on the distro, and since KDE decided KDE Neon IS A DISTRIBUTION this is on them to fix.

If I hear one word of “they use Ubuntu LTS, it is on them” then REMOVE THE PART ABOUT NEON BEING A DISTRO.

But then again, maybe this is now working and people no longer have problems.
But to point out, every single thing like this is on the distribution to handle.

I think it’s just that devs don’t know about the issue. I’m trying to figure out who’s responsible for firefox/apparmor configuration on kde neon dev chat.
I’ll keep you posted, but probably you just use the fix from github for now.

Oh, don’t get me wrong, I have no problem playing DRM content, my distro is handeling it for me.

Please do.
I do not ask for myself, I am asking because everything Neon is very badly documented, ie, no documentation at all.
So when trying to help others, it is very hard due to lack of info.
(I guess I ask for myself, but not really)

The thread is super old, so I do not even know if this is an issue on Neon any more, I was mostly reacting to what you typed.

It is apparmor and firefox apparmor profile problem: ppa - Netflix on Firefox: "The WidevineCdm plugin has crashed" - Ask Ubuntu
To fix the issue you need to edit the /etc/apparmor.d/usr.bin.firefox file and add:

owner @{HOME}/.{firefox,mozilla}/**/gmp-widevinecdm//libso m,

to the # per-user firefox configuration section. After that, you can reboot your computer (or reload AppArmor’s rules with apparmor_parser --replace /etc/apparmor.d/usr.bin.firefox) and everything will be working just fine :slight_smile:
Generally, I had not only this problem with apparmor and firefox - Plasma integration plugin not worked and Keepassxc plugin also not worked. I used this solution:
sudo ln -s /etc/apparmor.d/usr.bin.firefox /etc/apparmor.d/disable/
sudo apparmor_parser -R /etc/apparmor.d/usr.bin.firefox
This disables Firefox apparmor profile, and all plugins works fine.
I forgot - with apparmor Firefox profile enabled, my yubikey not works in Firefox also. With disabled profile - yubikey works fine.

disabling apparmor isn’t a solution though - it’s a bad workaround.
Afaik this issue has been sorted out in ubuntu but not in neon.
For Plasma-Integration this should work:
edit /etc/apparmor.d/abstractions/ubuntu-browsers.d/kde
add following on the end:
/usr/bin/plasma-browser-integration-host Cx → sanitized_helper,
(This should come to neon by itself as it has arrived in apparmor-master ubuntu-browsers.d/kde: fix plasma-browser-integration (!1115) · Merge requests · AppArmor / apparmor · GitLab , but the widevine part has not i think)

I think it is because in neon we were using firefox snap for a while but now reverted back to deb packages and didn’t tell apparmor about that.


Yes, I agree it is bad looking workaround, but I don’t have time to dive in apparomor configuration :wink: I’m using Neon and default is installed Firefox deb package. I don’t use Firefox snap package because of KeepasXC plugin - it doesn’t work with Firefox in snap.

I’ve checked this solution for Plasma integration plugin - it works. I have actualized Neon (with Plasma 6.02) and didn’t have this line in config.

glad I could help, but still - I want this fixed for everybody. No one feels responsible though

You inspired me, so I found solutions for:

Can confirm this fixed it for me as well. I recently did a fresh install but retained my /home so the Firefox settings and plugins came across without issue except for DRM content refusing to play and Plasma integration being broken, both of these appear to be due to apparmor and the more commonly suggested solution of simply disabling it for Firefox isn’t reasonable IMO.

This works while leaving apparmor in place!