Error in setting a default file type using dolphin

Image files are opeing with kate by default and when I try to set a default program to open a file, it’s showing this error - Could not find the “keditfiletype5” executable in PATH. I already installed kde-cli-tools but it’s still not working. I’m using arch and am new to linux.

how did you try to set the default program?

try this

click on the desktop, type “file associations”, and open the settings page from the search results

find .jpg in the list and set your application preference order.

1 Like

The same error is still there but I’ll deal with it later and it’s working for now how I wanted it to work. Thanks.

1 Like

i have a vague memory of something similar with dolphin shortly after install and i remember trying the flatpak version for a hot second before reinstalling the deb version.

since then didn’t have any issues.

you can try removing and reinstalling dolphin from the discovery app if you get desperate.

1 Like

that worked like a charm. thanks so much.

1 Like