Faster mouse pointer speed

Hi, I am using KDE Plasma 5.27.0 and Wayland.

Issue is moving my mouse across my screens seems to have slowed down recently, I have to do the “lift and skate” with the mouse frequently its annoying me now. To get the mouse across the two dual monitors.
I have maxed out the pointer speed and use adaptive in the mouse settings in plasma. If I move it to slow, its very slow so the slider is applying speed changes but at max its not enough.
Is there a way to boost the speed even more. To me its slower than in previous setups, sadly I cant pick when the change happened.

I have installed logitech Solaar to see if that helps, no difference.
Also I am not seeing all the mouse button options like side buttons. If in mouse settings, I use the click a button to map its not detecting the buttons, just left right and scroll?

this is the output of libinput for my Logitech M510 mouse which seems to match correctly.

 Device:           Logitech M510
Kernel:           /dev/input/event18
Group:            7
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   button
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   flat *adaptive custom
Rotation:         0.0


Try using an X11 session as the type of login and see if my memory is correct. I seem to recall reading of mouse issues when the Wayland session is used. When in the X11 session type xev in a Konsole and hit the enter key then press your buttons and see if it recognizes them all.

Hmm I am a little unwilling to switch back to X11 as I migrated now to Wayland, I would like it to work under wayland.

Up to you, but you get no idea if the bug(s) is/are in the Wayland that way.

True, I will give it ok after work today.

There is a way to do custom pointer acceleration but it is not implemented in the gui setting yet. Not sure if it is possible to do this from the terminal.

Did you use Evdev mouse driver instead of libinput before?

Do your mouse buttons work if you try them out in the debug gui?
sudo libinput debug-gui

OK I ran the debug-gui and I see it recognises the extra buttons and they work. The mouse pointer though started to wander off. See screen shot.

I am not sure if I had used Evdev driver before, I just let the default happen during the build process. This image is over a year old now.

I am not sure how to add/edit custom acceleration profile? The guide talks about the calculation but not how to set it up.

Ah ok, maybe issue with the mouse, I popped in an old wireless mouse and acceleration is back to normal. Still get the wandering mouse as per the screenshot in debug-gui but maybe then that is normal. As its certainly not a detected when using the mouse out side of that app.

So time to buy a new mouse. Thanks for the support though.

Good to read you got it resolved. I had one few weeks back when doing some testing that the numeric keypad was not giving me all the buttons on it when pressed. I was thinking it was the OSs tested that was the problem until the thought occurred to me to try spare keyboard laying around, then of course it works perfectly without the dying keyboard connected.